Support » Plugin: IP Geo Block » Recurring problem with ip-geo-block enabled

  • Resolved opsec

    (@opsec)


    when ip-geo-block is active on my sites, if i try to edit pages and click in the content area, the media modal comes up asking me to upload/insert media and it cannot be closed. I have to hit the “back” on my browser to get out, disable the ip-geo-block plugin, then i’m allowed to edit the page as normal.

    This started a few weeks ago and I thought I’d just wait for an update, but I think 2 have happened since this started occurring and it hasn’t fixed it.

    There are no console errors in chrome inspector or ff inspector so it’s pretty difficult to debug with no messages, only annoying behavior that disappears when ip-geo-block is active.

    https://wordpress.org/plugins/ip-geo-block/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author tokkonopapa

    (@tokkonopapa)

    Dear opsec,

    Thank you for reporting this issue. Unfortunately I can’t debug now since I’m on my business trip. After returning to my home, I’ll try to reproduce what you reported.

    Please keep tracking this issue.

    opsec

    (@opsec)

    no problem, cheers.

    Plugin Author tokkonopapa

    (@tokkonopapa)

    Dear opsec,

    I’m sorry that I kept you waiting. Now I’m home.

    First of all, I’d like to confirm the process of making your issue.

    1. Go to dashboard.
    2. Menu “Pages” –> “All Pages” or “Add New”
    3. Select one of pages to “Edit” if you select “All Pages” at 2.
    4. Put the cursor on the text area. (either “visual” mode or “text” mode)
    5. Media modal comes up !

    Unfortunately, the above process can’t reproduce the issue. I think the issue may be caused by the same reason as “Conflict with Menu Editor plugin?“. Because this plugin will try to embed a special crafted nonce when you click anchor tags and submit button of forms. This mechanism has been implemented since version 2.0.x.

    So I’d like to ask you to report the name of plugins you’re using, or identify the conflicting plugin by deactivating all the plugins (except this one) then activating one by one.

    Everytime I greatly appreciate your cooperation to improve this plugin!

    Thanks so much.

    Plugin Author tokkonopapa

    (@tokkonopapa)

    This issue was the same as “[resolved] Cannot edit pages when ip-geo-block is enabled” and will be fixed in version 2.2.3.

    Thanks.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Recurring problem with ip-geo-block enabled’ is closed to new replies.