Support » Fixing WordPress » Recurring problem – can’t write new posts or edit old ones

  • I’ve read other forum posts on this topics and no solution seems to work for more than a day or two. I’m intermittently having problems writing posts or editing old ones. This happens on both my blogs, which use different themes, by the way.

    Here’s an example of a typical error message I get when opening the “write” tab to create a new post:

    Line: 176
    Char: 290
    Error: Access is denied.
    Code: 0

    I have tried:

    • Turning off all plugins
    • correcting the path for new posts, per other forum posts on this topic, to include “www.”; under General Options, I edited so that it says “” for the WordPress address and “” for the blog address
    • Checking to be sure that I have the latest version of WordPress installed
    • Replacing the WordPress files anyway, just in case something got corrupted
    • Checking with my host to see if THEY have changed or updated anything (they haven’t) or if they see anything I should correct (they suggested I contact WordPress support)

    If anyone can suggest some avenue I haven’t explored, I’m all ears. One request: Please speak in simple terms — I’m an amateur, although I can follow step-by-step instructions.

    Thanks for any advice!

    – Carolyn

Viewing 8 replies - 1 through 8 (of 8 total)
  • Had a second thought: Why does the error message say that WordPress is trying to write to:


    when I’ve actually set the path to include the “www”?

    I don’t understand …

    One last comment: The WordPress Codex says file permissions for the wp-admin folder (which is where these error messages all come from) should be set so only the user account can write to them. Is that correct? Does that mean setting it to 666, or what? Would it help or create problems if I gave more liberal permissions? (I’ve tried up to 776 without any improvement.)

    Update: Fixed (at least for now). At the suggestion of my host, I tried using a different browser to access my WordPress admin interface. I was *very* doubtful this would help, but gave it a go. I installed the latest version of Opera … and whaddaya know … now I can write new posts without problems.

    Could it be something as simple as an incompatibility between WordPress 2.2 and Internet Explorer 7.0.5730.11?

    Sheesh. I’d still love to hear some feedback from the WordPress experts anyway. Sorry for the flood of info from me, but I figured too much was better than not enough. 🙂

    Moderator Andrew Ozz


    WordPress Dev

    The error you mention in your 1st post looks like a javascript problem. Have you tried deleting your browser’s cache? Or perhaps you have installed some kind of anti-spyware program on your PC that restricts the js in IE?

    In any case, try using FF, as Opera is not fully supported by TinyMCE (the wysiwyg editor).

    Hi, Azaozz,

    I’ll try deleting my browser’s cache; thanks. Does this mean you think it might be a problem with cookies? If so, is there a long-term fix you’d recommend?

    My antivirus/spyware programs all pre-exist my installation of WordPress and didn’t interfere with it initially. The problems started when I upgraded to 2.2. I use McAfee VirusScan Enterprise 8.0.0 (my office provides it to us for home office use so we don’t upload viruses to the office network when working from home). I have Spybot and Ad-Aware on my computer but only run them when I have problems (many months ago).

    I will try Firefox, thanks; I’ve avoided it since my early adopter experience with it wasn’t so great but will give it another try. I just noticed some issues with Opera today, although they are minor compared to the “I can’t write new posts” dilemma; using Opera seemed to fix the posting/editing problem. (One Opera issue is that the field where I type new posts sometimes seems to lose word wrap capabilities; a paragraph will go off endlessly to the right. Arrgh.)

    Thanks for taking a look at this. — Carolyn

    We’ve been having the same problem. We tried clearing the cache, we’ve tested on a number of different browsers by a number of different people.

    That I can tell, the problem exists solely on the Windows Vista systems, and solely with the Internet Explorer browser.

    I was having the same problem – check out my post to see if it is helpful:

    Don’t give up on Opera so easily. I use a text editor to write out my post and then paste it into the text field once I’m happy with it. It’s an extra step in one sense, but it feels more natural to compose in a text editor than in a text field. I do hope they will get this wrapping problem sorted out though. It’s annoying.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Recurring problem – can’t write new posts or edit old ones’ is closed to new replies.