Support » Plugin: Events Manager » recurring events – how to limit number that display without changing dates

  • Resolved annafjmorris

    (@annafjmorris)


    Hi, I use recurring events and one off events but I don’t want a ton of recurring events to show at the end of my one off events. If I just leave the events running I end up with this at the end of my calendar:

    Last one off event I added – date – time
    Recurring event 1 – date – time
    Recurring event 2 – date – time
    Recurring event 1 – date – time
    Recurring event 2 – date – time
    Recurring event 1 – date – time
    Recurring event 2 – date – time
    Recurring event 1 – date – time
    Recurring event 2 – date – time

    etc

    I have been therefore manually extending the date range of my recurring events each month when I do the one off events for the month, but it takes more time than I would really like to spend.

    Is there any way to just say “for recurring events only show 4 weeks into the future” or use a global end date for all calendar items to display?

Viewing 15 replies - 1 through 15 (of 19 total)
  • Plugin Support angelo_nwl

    (@angelo_nwl)

    at the moment you can try to use events_list shortcode with search attributes such as scope, order and orderby

    https://wp-events-plugin.com/documentation/event-search-attributes/

    https://wp-events-plugin.com/documentation/shortcodes/

    Below is what I use to limit recurring events on a printed report.

    [events_list category=’55’ scope=”future” limit=”2″]
    #_EVENTDATES …
    [/events_list]

    ~April

    Hi april, thanks for the help – I can’t seem to get this working – I used the exact same code you pasted and it’s showing events a long way in the future

    https://www.stoswalds-knuzden.org.uk/events/

    any ideas?

    hum I have trired a lot of things now

    variations of the shortcode including examples stated elsewhere
    removing the CONTENTS tag
    saving the events manager settings to refresh css
    changing to a default wordpress them
    clearing the cache
    new private window

    nothing seems to be working, it’s very confusing!

    Anna, I saw that your first post was 2 weeks ago. It took EM more than 1 week to give you a two line response. Is that common for EM?

    Patrick

    (@duisterdenhaag)

    Jing, please stop nagging!

    I don’t know, I am happy with the response so far, it’s been helpful. If I wanted a faster response I would try an IRC forum.

    Anyone have any additional help with this issue?

    Anna, what is the IRC forum?

    Is it the Pro Forum?

    Patrick

    (@duisterdenhaag)

    Hi Anna,
    Just so I get it right… You are talking about the Events List, right (Calendar may be confused with WP Fullcalendar)? 😉

    There are two ways to output your events list to the front-end:
    1) Using a shortcode [events_list]
    2) Using the Events > Settings > Pages > Event List/Archives.

    Option 1 is most flexible (due to arguments) and can be used on any page.

    The limit at the end of the settings page is only to start the pagination after x events. The arguments in the shortcode will allow you to manipulate that a bit more.

    What EM does is overwrite everything in your assigned Events List Page, unless you have CONTENTS in there somewhere – then it will only overwrite that part. But still, it will use the settings in the EM settings. So, no limit 🙁

    To keep (other) benefits, but prevent EM from overwriting your Events List Page content, wrap CONTENTS in a hidden div in your Edit Page.
    <div class="none">CONTENTS</div>

    Then you can use the shortcode [event_list limit=”10″] to only output 10 events, regardless of how many there are in your back-end.

    This way, EM can still do what it needs to do, but the visitor won’t see it, as you’ve hidden that from view.

    In my opinion, the biggest benefit of using the shortcode are the arguments.
    “limit” normally tells EM to limit that amount of events per page. The shortcode allows you to disable pagination:
    [events_list limit=”10″ pagination=”0″]

    • This reply was modified 8 months, 1 week ago by Patrick.

    Patrick, what a great guy!

    Do you happen to have any more insight on how to make the search thing work? We have been tickering for yet another day without knowing what went wrong.

    Thanks a lot Man!

    Jing

    Patrick,

    We found this:

    – If you deactivate WP Full Calendar, and in the Events setting, choose No to Calendar display, Yes to display search box. Only include “Contents” in the Events page. No shortcode. Then the Search box will start working as expected. You will get a list view.
    – If you activate WP Full Calendar, it will overwrite the setting, and the Search box will stop functioning.

    Are you seeing the same? It looks like an opportunity to improve the design. Thoughts?

    Jing

    Patrick

    (@duisterdenhaag)

    Jong, STOP THIS NOW!
    It extremely annoying that you are now trying to abuse another thread to get an answer.

    Your post has NOTHING to do with Anna’s question, so I will NOT got into it here!

    Patrick

    (@duisterdenhaag)

    @annafjmorris, to get back on topic… did my answer help you? Still have questions?

    My apologies.

    Points taken.

    Hi Anna,

    I am a relative beginner to websites, but do have this working on my site. But I’d be very happy to try to paste your exact code into a page in my website …and see if it works. Perhaps I’ll see something that would be helpful.

    ~April

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘recurring events – how to limit number that display without changing dates’ is closed to new replies.