Support » Plugin: WP Recipe Maker » Recipe Schema not added to Graph when using Elementor Block

  • princesshorsepower

    (@princesshorsepower)


    When I use the WPRM Recipe Elementor Block the Schema is not added to the Yoast schema graph. The whole Recipe Graph is missing.

    When I use the Shortcode Block in Elementor [wprm-recipe id=”…”] it works.

    Using
    – WPRM 5.4.1
    – Yoast SEO Premium 11.8

    On my staging system I deactivated all other plugins to make sure it’s not a plugin conflict. Any ideas?

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Brecht

    (@brechtvds)

    Thanks for the details, I’ll be able to do some testing in the next few days.

    Does the metadata show up when you deactivate the Yoast integration on the WP Recipe Maker > Settings > Recipe Metadata page?

    Thread Starter princesshorsepower

    (@princesshorsepower)

    No, same behavior when disabled

    Plugin Author Brecht

    (@brechtvds)

    Is it only a problem when Yoast is activated or is it an Elementor compatibility issue?

    Thread Starter princesshorsepower

    (@princesshorsepower)

    It does even not work when yoast is deactivated.

    Btw use
    Elementor 2.6.7
    Elementor Pro 2.6.3
    Theme Elementor Hello with a single post template

    Plugin Author Brecht

    (@brechtvds)

    Is Pro needed to replicate the problem? Same issue with a default theme (like Twenty Nineteen)?

    Thread Starter princesshorsepower

    (@princesshorsepower)

    Ok… It’s definitely Elementor Pro.
    When I deactivate it it works.

    Plugin Author Brecht

    (@brechtvds)

    That’s why I haven’t been able to replicate it. Would it be possible to send a copy of that plugin to support@bootstrapped.ventures so I can do some testing?

    Thread Starter princesshorsepower

    (@princesshorsepower)

    I’ll do that tomorrow… Thx for your support

    Plugin Author Brecht

    (@brechtvds)

    Could you try updating to the latest 5.4.3 version and see if it works then?

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Recipe Schema not added to Graph when using Elementor Block’ is closed to new replies.