Support » Plugin: WP Recipe Maker » Recipe Ratings Not Sticking

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Brecht

    (@brechtvds)

    Not sure what’s going wrong here. Most likely some kind of compatibility problem.

    Try disabling all other plugins for a second and see if it works then.
    If not, try switching to a default theme (like Twenty Seventeen) and check again.

    So here’s a weird thing. Google is suddenly picking up the ratings, and I didn’t disable or update any plugins. What’s weird is that when I view the recipes in an incognito window, I’m showing zero ratings still. And when I leave a star rating, and then refresh the page, the star rating it gone. I’ve even tried leaving a rating from my phone, where I’m not logged into my site, and even through a proxy server with a EU IP. WPRM ratings are acting unpredictably.

    Scratch that, it’s still broken on a lot of my recipes, but for ONE recipe it happens to be working. Sigh.

    It’s working on this one:

    https://fearlessfresh.com/how-to-cook-spaghetti-squash-in-the-microwave/

    But not on these:

    https://fearlessfresh.com/how-to-roast-a-turkey/
    https://fearlessfresh.com/can-you-cook-quinoa-in-a-rice-cooker/

    Plugin Author Brecht

    (@brechtvds)

    Did you do the compatibility problem test?

    You could also check with your webhost if there are any specific errors in the PHP error log that could point us in the right direction.

    I did try turning off all the other plugins and it did not make a difference. My webhost wants to know what php error they’re looking for?

    Plugin Author Brecht

    (@brechtvds)

    Did you test with a default theme and no other plugins enabled?

    I’m not sure what the error would be. Ideally you don’t want any errors in the log.

    juusan

    (@juusan)

    YES. Can we finally start troubleshooting your plugin now?

    Plugin Author Brecht

    (@brechtvds)

    This is troubleshooting. The feature works for thousands of users so the first step is always to test with everything else disabled. Feel free to email us at support@bootstrapped.ventures to speed up the process.

    Did you get that error log?

    juusan

    (@juusan)

    I have Cloudways and their support sucks, and they refused to pull the log. They told me to hire a developer to do it. I was able to pull this from the server. Is this what you need?

    https://eatre.al/332b0RT

    Plugin Author Brecht

    (@brechtvds)

    That looks like the server access log and not the PHP error log. Does that one happen to be there as well?

    Could you email it to us at support@bootstrapped.ventures
    That will speed things up a bit as you’ll end up in our support system.

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.