Support » Plugin: Mailjet Email Newsletter Marketing » Recently breaks the site

  • Xonium

    (@xonium)



    Not sure exactly at what version it started to break the site. 5.0.6 breaks the site, so did 5.0.5.
    Not the whole site entierly but several parts of Admin area.

    For example theme customizer and widgets breaks.

    The plugin itself (/wp-admin/admin.php?page=mailjet_initial_contact_lists_page) can’t be reached. Throws Error 500.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Xonium

    (@xonium)

    PHP is version 7.2

    Plugin Author Mailjet

    (@mailjet)

    Hello Xonium, sorry to hear you are facing issues with the plugin. We are trying to reproduce the issue but with no success.

    Please can you check the Apache logs of your server and let us know if you find the Error 500 there. Please send us the full error text so we can see what is causing the problem.

    What about the theme customizer and widgets – do you get Error 500 there as well? What theme are you using – maybe it is something specific related to a certain theme?

    • This reply was modified 1 month ago by  Mailjet.
    Plugin Author Mailjet

    (@mailjet)

    Hello @xonium, please can you provide some more details about the issue so we can try to fix it or you? Just leaving a poor rating doesn’t help anybody.

    Kind regards,
    Mailjet Plugins team

    Hi. After further inspection. It’s a clash between mailjet plugin and Klarna (Sweden’s probably largest payment provider/system/plugin).

    They seem to hook onto wordpress email functions. And mailjet’s plugin obvisously modifies wordpress email functions so much as it breaks completely.

    Considering Klarnas plugin has worked forever, it hasn’t changed. But the errors started occuring recently with a change in mailjet plugin. Everything works fine with mailjet disabled. WordPress/Woocommerce with Klarna plugin works perfectly when mailjet doesn’t modify the email functions. I must consider the mailjet plugin to be at fault here.

    PHP Fatal error: Uncaught InvalidArgumentException: allow_redirects must be true, false, or array in .../wp-content/plugins/woocommerce-gateway-klarna/vendor/guzzlehttp/guzzle/src/Message/MessageFactory.php:203\nStack trace:\n#0 /.../wp-content/plugins/woocommerce-gateway-klarna/vendor/guzzlehttp/guzzle/src/Message/MessageFactory.php(98): GuzzleHttp\\Message\\MessageFactory->applyOptions(Object(GuzzleHttp\\Message\\Request), Array)\n#1 .../wp-content/plugins/woocommerce-gateway-klarna/vendor/guzzlehttp/guzzle/src/Client.php(120): GuzzleHttp\\Message\\MessageFactory->createRequest('GET', 'http://api.mail...', Array)\n#2 .../wp-content/plugins/woocommerce-gateway-klarna/vendor/guzzlehttp/guzzle/src/Client.php(125): GuzzleHttp\\Client->createRequest('GET', 'http://api.mail...', Array)\n#3 [internal function]: GuzzleHttp\\Client->get('http://api.mail...', Array)\n#4 .../wp in .../wp-content/plugins/woocommerce-gateway-klarna/vendor/guzzlehttp/guzzle/src/Message/MessageFactory.php on line 203

    In widgets. All widget areas are just gone.
    Basically wordpress outputs all HTML until I guess it’s supposed to run the mailjet plugin code. Then it interrupts. No visible errors.

    This is the last html source code in widgets page:

    
    			<span class="screen-reader-text">Mailjet Subscription Widget</span>
    		</a>
    	</div>
    	<div class="widget-title"><h3>Mailjet Subscription Widget<span class="in-widget-title"></span></h3></div>
    	</div>
    
    	<div class="widget-inside">
    	<form method="post">	<div class="widget-content">	

    In theme customizer. There in only html output from mailjet plugin. Nothing from wordpress. This is 100% of the html source code in theme customizer:

    <div id='widget-18_wp_mailjet_subscribe_widget-__i__' class='widget'>	<div class="widget-top">
    	<div class="widget-title-action">
    		<button type="button" class="widget-action hide-if-no-js" aria-expanded="false">
    			<span class="screen-reader-text">Redigera widget: Mailjet Subscription Widget</span>
    			<span class="toggle-indicator" aria-hidden="true"></span>
    		</button>
    		<a class="widget-control-edit hide-if-js" href="/wp-admin/customize.php?return=%2Fwp-admin%2Ftheme-editor.php&editwidget=wp_mailjet_subscribe_widget-1&addnew=1&num=2&base=wp_mailjet_subscribe_widget">
    			<span class="edit">Redigera</span>
    			<span class="add">Lägg till</span>
    			<span class="screen-reader-text">Mailjet Subscription Widget</span>
    		</a>
    	</div>
    	<div class="widget-title"><h3>Mailjet Subscription Widget<span class="in-widget-title"></span></h3></div>
    	</div>
    
    	<div class="widget-inside">
    	<div class="form">	<div class="widget-content">
    Plugin Author Mailjet

    (@mailjet)

    Thanks for the details. We will investigate the issues and hopefully will come back with an update. I’ll let you know as soon as we pinpoint the root causes.

    Kind regards,
    Mailjet Plugins team

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this review.