Support » Plugin: W3 Total Cache » Recently an error occurred while creating the CSS / JS minify cache

  • I’m frequently getting this error that has been reported a year or two ago, I wanted to bring it up and see if anyone has a resolution? The threads on this issue are old and closed and state it was to be fixed in a new version. I’m running the latest, 0.9.3 of WTC.

    “Recently an error occurred while creating the CSS / JS minify cache: A group configuration for “include-body” was not set. “

    Thanks,

    Chris

    https://wordpress.org/plugins/w3-total-cache/

Viewing 15 replies - 1 through 15 (of 25 total)
  • I too am getting the same error. And I too noticed that old threads said the problem was fixed in the “new version.” Not true.

    Can anyone help?

    Many thanks.

    Tim

    https://wordpress.org/plugins/w3-total-cache/

    Indeed I have this problem also (it also causes errors with google): http://wordpress.org/support/topic/minify-errorinternal-server-error-500?replies=1

    I have had no replies in 5 days but I have another thread (which I pretty much resolved myself) from over 4 weeks ago that hasn’t had any responses

    Do the Devs of W3 not care about their customers?
    Poor service at free level will not inspire me to pay for the premium support, quite the opposite… all it will achieve is me looking for another plugin.

    From other sites where I have been trying to resolve the problem a lot of people say “Switch to Varnish”

    I get this error when I uninstalled a plugin that was used before. It’s been that way for 2 months but I ignore it because it still works the way it does.

    Recently an error occurred while creating the CSS / JS minify cache: File “/var/www/vhosts/site.com/httpdocs/wp-content/plugins/mini-twitter-feed/minitwitter.css” doesn’t exist.

    I’m guessing you have to use paid support to get this resolved.

    The Odd Duck,

    Did you switch to Varnish? If so, did that fix it?

    I had turned of the “Enable Minify” then reactivated… I thought that had solved the problem, but the error message is back again.

    Cheers,

    Tim

    I didn’t switch to varnish because when i looked at the plugin it said it was only compatible up to 3.5.2

    I might try it out on my other blog that currently has no caching at all though.

    I’ve paid for the PRO version only to find out that it doesn’t come with support. I tried to report this same bug (which apparently has been happening for years) but even their trouble ticket site has a bug! I couldn’t report it.
    So, what did I pay for PRO support for???

    Despite having turned off both the minify for the JSS and the CSS, I am still getting the error.

    ?

    So if we can’t seem to get any support from the makers of W3 Total Cache, can we start a list of alternatives? Does anyone have a recommendation on the best javascript minify plugin?

    Me too. I run a number of sites and it only appears on a few of them. No idea what the issue is though as I can’t see any way of finding out further information.

    I get it every once in a while. Sometimes the cache hiccups. It can be a goofy bug. Is your site working properly? Any white screens of death? Any logged errors? Anything broken?

    Here’s some settings I would recommend if you are going to use minify. Set properly, it can make a site load faster with caching and a CDN in place. (I use Google PSS for CDN.)

    General Settings-
    Minify: Enabled
    Mode: Manual (Auto can be way too aggressive for many.)
    Cache: select yours (I have APC installed and use it.)
    HTML minifier: default
    JS minifier: JSmin (default)
    CSS minifier: default
    Save the settings.
    Clear page Cache.

    Under Minify-
    Rewrite URL structure- checked
    Disable for logged in users- checked
    HTML & XML section-
    HTML: check only the following
    Enable
    Inline JS
    Line Break Removal
    Ignored comment stems:
    google_ad_
    RSPEAK_
    Save the settings.
    Clear Page Cache.

    Under JS- (now, I had to play with these,but what follows is the best practice)
    Enable- checked
    Under Operations:
    Before- minify- non blocking using Async
    After- minify- non blocking using Async
    Before- minify- non blocking using Async
    JS file management- make sure your theme is selected
    Save the settings.
    Clear Page Cache.

    Under CSS-
    Enabled-check
    Line break removal- check
    Preserved comment- check
    @import handling- none (you don’t want anything else but this.)
    CSS file management- make sure your theme is selected
    Save the settings
    Clear Page Cache

    Advanced:
    Update external files: 86400 seconds

    Save the settings.
    Clear page cache.

    Test your site as you make these changes being sure to hit Cntl F% for a hard refresh to rebuild cache.

    If you find one group that doesn’t seem to work right, turn off all the options under Minify and test them one at time turning them back on until you find the one causing an issue.

    This is what I did and am successfully using Minify now.

    For the first 24 hours you may see that goofy minify bug while the cache is building.

    I’ll have a play later…

    nothing on the site is broken, it just seems to be that google cannot render the pages properly and returns a 500 internal server error

    I will take a look at what you have suggested though…

    I still think it is disgusting that there is no support offered by the plugin makers
    Especially for the dude that paid for the pro version!

    It’s not Google. It’s the sql server. Turn off database caching for starters and test it. 🙂 Caching a relational database can cause 500 range errors.

    Hit me back and let me know.

    Thanks for the suggestion @leslie1019wp.

    Unfortunately DB caching was already turned off long ago and I’m still getting the errors.

    At work at the mo so I will have to try that later.

    so even though humans do not experience the 500 internal server errors – google does because of the database caching and is completely unrelated to the minify issue?

    so let me get this straight

    The database caching causes issues with google
    The minify thing not working is unrelated

    I still have to try out all the suggestions above, I have been rather busy the last few days though..

    I just want to let everyone know that I’ve deactivated the W3 Total Cache and the website is loading faster than before.

    Yes, this plugin is seeming more and more like a scam to me. When I bought the PRO version, I immediately got an email offer to “optimize” my site for $250. Later, when I complained about the bugs (which I had to do by choosing “Request a Quote” in their online contact form since they don’t respond otherwise) they told me that the PRO version does not include support. They then again offered to “optimize” my site for $250.

    I’m going to try disabling it to see if there’s any difference in page load speed.

Viewing 15 replies - 1 through 15 (of 25 total)
  • The topic ‘Recently an error occurred while creating the CSS / JS minify cache’ is closed to new replies.