Support » Plugin: PayPal for WooCommerce » Recent Upgrade to Version 1.5.5 Causing Issue

  • Hi guys,

    I recently upgraded the plugin to Version 1.5.5 and now when I place an order if logged in I get the following error:

    Cannot provide both paymentMethodToken and creditCard attributes. Credit card must include number, paymentMethodNonce, or venmoSdkPaymentMethodCode.

    This wasn’t happening previously, any tips on how to resolve? If not I will roll back the plugin to the previous version.

    Thanks in advance.

Viewing 8 replies - 1 through 8 (of 8 total)
  • I’ve rolled back the plugin to version 1.5.4 and successfully placed an order whilst logged in. Note: whilst using version 1.5.5 when not logged in there were no issues.

    This proves a change was made in 1.5.5 that’s causes the following response from the Braintree API:

    [0] => Braintree\Error\Validation Object
    (
    [_attribute:Braintree\Error\Validation:private] => base
    [_code:Braintree\Error\Validation:private] => 91515
    [_message:Braintree\Error\Validation:private] => Cannot provide both paymentMethodToken and creditCard attributes.
    )

    )

    Hope this helps point you to the piece of code throwing this exception.

    • This reply was modified 10 months, 3 weeks ago by markdendy2804.
    Plugin Contributor angelleye

    (@angelleye)

    Thanks for the info. We’re looking into this now to see if we can reproduce the problem, and we’ll get an update released ASAP!

    I’m also experiencing failed transactions and receiving this error message. I had 1.5.7 installed and following the lead of @markdendy2804 I reverted to 1.5.4 and transactions seem to be processing normally again.

    Let me know if there’s any other info I can provide that would be of use.

    Plugin Contributor Oliver

    (@angelleyesupport)

    @llcodyson Thanks for bringing this to our notice. We are already working on this and will get this resolved soon. Please bear with us a for some time.

    Thanks!

    inspired888

    (@inspired888)

    Was this issue resolved? I experience something similar.
    I’ve not figured out all the ways it is triggered, but here’s what I know so far.

    1. When testing a checkout, without user logged in (new user), it wouldn’t process at all. I’ll need to run that test again.

    2. When making an order (as my admin user, which has WC history, payment data stored, etc.), I got the message Cannot provide both paymentMethodToken and creditCard attributes. Cannot use a paymentMethodNonce more than once. Cannot use a paymentMethodNonce more than once. Credit card must include number, paymentMethodNonce, or venmoSdkPaymentMethodCode.

    3. When logging in as a test customer first, and then checking out, I was able to make payment.

    4. Then I tried to make another purchase with that same customer, same session (right after purchase in #3 above). I tried to use the store/saved card (from purchase #3 above). I get the message, “Cannot provide both paymentMethodToken and creditCard attributes. Credit card must include number, paymentMethodNonce, or venmoSdkPaymentMethodCode.”

    Is this related to issue of OP, or should I start a new support thread?

    Thanks,

    Jonathan

    Plugin Contributor Oliver

    (@angelleyesupport)

    Hi @inspired888 ,

    Well this issue is still active and will need some updates in the new BT integrations which is already in process and soon we will release a hotfix for this.
    We appreciate your patience till then.
    Thanks!

    Just been asked to look into what has turned out to be this issue. Hoping this hotfix is coming soon

    Plugin Contributor Oliver

    (@angelleyesupport)

    @photel Yeah we will release it soon.

    Thanks!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Recent Upgrade to Version 1.5.5 Causing Issue’ is closed to new replies.