Support » Plugin: Schema » Recent update showing AMP errors

  • Resolved SabariNath

    (@techlog360)


    After last update plugin is showing some error with AMP integration. All amp pages are showing invalid while testing when Schema plugin is active.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Same problem on AMP pages. This is the error shown:
    Warning: in_array() expects parameter 2 to be array, null given in /…/wp-content/plugins/schema/includes/integrations/amp.php on line 29
    Had to disable the plugin.

    • This reply was modified 3 years, 9 months ago by chusterclock.
    Plugin Author Hesham Zebida

    (@hishaman)

    I will check soon and fix this.

    Plugin Author Hesham Zebida

    (@hishaman)

    Ok, I think I got this fixed. I’ve updated the plugin files here on wp.org, please download and install a fresh copy of the plugin and try it out.

    Let me know how it goes.

    Hello @hishaman,

    I don’t understand what’s happening 🙂

    It seems version number of your plugin (1.7.2) still remains the same before your last update (8 hours ago right now).

    I did download your fresh version… and yes: the warning (not a notice, but a warning) gone away.

    May you help me to understand what’s up with versioning?

    Cheers

    Plugin Author Hesham Zebida

    (@hishaman)

    Hi, thanks for getting back to me @daweb

    I did a soft update for just one of the plugin files, this will change last updated time, but keep version as it is. I do this not to trigger the plugin update notification.

    Version 1.7.3 is on its way, will be released soon with other fixes.

    Thank you for reply @hishaman. I thought I was crazy, then GIT clarified to me something… files modified were 3, not just 1 (just to say).

    My very best

    Plugin Author Hesham Zebida

    (@hishaman)

    Yes, the other two files has been modified to solve other issues found in the plugin 🙂

    hi, I have this problem
    Warning: in_array() expects parameter 2 to be array, null given in …………/wp-content/plugins/schema/includes/integrations/amp.php on line 29

    Same problem here
    Sorry, I was checking a old log

    • This reply was modified 3 years, 7 months ago by nicocaldo.
Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Recent update showing AMP errors’ is closed to new replies.