Support » Plugin: Store Locator PlusĀ® for WordPress » Recent Update Killed It

  • Resolved codiller

    (@codiller)


    Upon upgrading, I received this error: PHP Fatal error: Cannot use object of type WP_Site as array in /nas/content/live/prmisf/wp-content/plugins/store-locator-le/include/class.activation.php on line 334

Viewing 2 replies - 1 through 2 (of 2 total)
  • cicistorelocatorplus

    (@cicistorelocatorpluscom)

    Please post in the SLP forums for best results include your Plugin environment and other info requested in the Read before posting guidelines.

    Plugin Author Store Locator Plus

    (@charlestonsw)

    This is fixed in SLP 4.6.2

    WordPress changed version 4.6 to deprecate wp_get_sites() which returned an array.

    They now require get_sites() which returns an object.

    Thanks to these changes in WordPress, Store Locator Plus now needs to carry around a lot of extra code to basically say “If you are on Multisite and are using WP 4.6 do this… if you are on on Multisite and less than WP 4.6 do that… and if you are NOT on multisite do something completely different”.

    As an aside, most of the multisite support options are built into the Premier Plugin for Premier Subscription users. If you are running multisite you really should be enrolled in our Premier program.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Recent Update Killed It’ is closed to new replies.