Forums » Plugin: MasterStudy LMS WordPress Plugin – for Online Courses and Education » Recent update has added empty video on top of every class

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Support mgordonStylemixThemes

    (@mgordon7)

    Hello,

    Recently our dev team uploaded newer version of the LMS plugin. Please try to update the LMS plugin to the latest new version and recheck from scratch

    Best regards

    Thread Starter boxhamster

    (@boxhamster)

    I’m on Version 3.2.3 now. Same issue.

    davidstylemixthemes

    (@davidstylemixthemes)

    Kindly, note that as you mentioned, you are using HTML source type video lessons, but inserting video using Elementor. Meanwhile, you are leaving video upload field on Course Builder empty. [screenshot]

    As a result, you are getting non-functional video player. Please, note that once you are using video type lesson, you must show the source of the video also on Course Builder. Otherwise, it will be just an ordinary text lesson.

    To fix the issue, open a lesson on Course Builder and assign video to every single video lesson. Then, open it on Elementor, and remove those videos. Otherwise, video players will be doubled.

    Let us know if there will be any further questions.

    Best Regards

    Thread Starter boxhamster

    (@boxhamster)

    Thank you.
    The mentioned fix is not viable for me as I use Elementor’s conditions to show certain videos for certain users and also dependent on the language.

    Considering this issue is new, I’d like to understand what has changed in the recent versions and why this was changed?

    Plugin Support mgordonStylemixThemes

    (@mgordon7)

    Thank you for the details shared, the LMS plugin is not part of the Elementor plugin in general, and all the Course and lessons should be now included with the default Course Builder of the LMS plugin, if you are creating Video lessons, you need to upload videos with the Course Builder. The Elementor plugin doesn’t include option to control the Course builder as the structure of both plugins are not the same, these factors depend not only on the LMS but on the Elementor plugin as well. So, the best solution for you will be using the Course Builder of the LMS plugin properly, without trying combining to avoid unexpected issues

    Best regards

    Thread Starter boxhamster

    (@boxhamster)

    Thank you for your reply, but your solution doesn’t work for me as I need Elementor’s capabilities for my use case, I’m afraid.
    I was however able to work around the issue just switching all classes (all 110 of them…) manually to the “Embed” type (instead of HTML (MP4)) and that removed the empty video frame.
    I would like to point out that this is a new issue introduced recently and had a lot of users write saying that the videos are not playing anymore.

    jacobstylemixthemes

    (@jacobstylemixthemes)

    Hello,

    Thank you for your reply

    If the solution does not work for you with new version of the MasterStudy LMS, you are welcome to rollback it using https://wordpress.org/plugins/wp-rollback/ plugin. It helps you to revert the MS plugin version to which your classes are compatible with Elementor’s embedded videos

    Hope it helps

    Regards,

    Jacob, Support Team

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.