WordPress.org

Forums

Recent server change, permalinks, images not uploading (11 posts)

  1. oddmango
    Member
    Posted 2 years ago #

    I recently changed servers and had a bit of a rough time moving.

    1) I couldn't get my blog to work so I ended up changing permalinks to default, which is the only one that works. Previously they had been "Post name", which I'd prefer. I had to delete .htaccess in order to get the site to work. Not sure how or why...

    2) I've been mucking around with the featured images and thumbnails, so I'm not sure if that has broken things.

    3) When uploading an image several bad things are happening.
    - The uploaded image in the media browser is broken.
    - The image will be broken if selected as featured image (as seen in backend) or inserted into the post.
    - The image will show up as featured image only in certain circumstances.

    This URL works:
    http://readysetfork.com/recipes/wp-content/uploads/recipebutton.jpg

    But this, the automatic URL, doesn't:
    http://readysetfork.com/recipes/wp-content/uploads/recipebutton-300x137.jpg

    Take a look here to see what is happening: http://readysetfork.com/recipes/

    Thanks in advance for your help.

  2. Krishna

    Posted 2 years ago #

    Deactivate all plugins, revert to Twenty Twelve theme and try to change permalinks. Perhaps it will also solve other problems that you have now. If you cannot do via dashboard, use FTP/ hosting control panel.

  3. oddmango
    Member
    Posted 2 years ago #

    It seems one naughty plugin was responsible for the broken images, thanks for that! I tried reverting to twenty twelve but it made no difference to permalinks. Does my lack of .htaccess file really not matter?

  4. wspencer
    Member
    Posted 2 years ago #

    Did you update the database name in your wp-config file? Sometimes web hosts will have different database name structures.

    For example, I moved a site from Host A to Host B. On Host A, my database name was "wordpress". When I moved to Host B, I had to include my web host username as a prefix for the database, so I had to change the wp-config file to "username_wordpress".

    Check with your web host about that before making any changes to your wp-config file! This was just the first thing I thought of after reading your post.

  5. oddmango
    Member
    Posted 2 years ago #

    Yes, I did update my database in wp-config. I can access, read and write to the new database, but only if permalinks are set to default. Otherwise I get a 404 error. :(

  6. wspencer
    Member
    Posted 2 years ago #

    The htaccess file that WordPress edits will put in your rewrite rules. If you don't have an htaccess file at all...that is going to cause some problems.

    Upload a standard .htaccess file first. Then change your permalinks from the default setting to the /%postname%/ and save. See if that works for you

  7. oddmango
    Member
    Posted 2 years ago #

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    That is my .htaccess in my root folder, but it's still not working.

    (Thanks for all your help guys, I really appreciate it!)

  8. Krishna

    Posted 2 years ago #

    Do you find any login problems? If not, please go to your dashboard and delete the plugin recipe-card and try to reset your permalinks. You can re-upload the plugin later.

  9. oddmango
    Member
    Posted 2 years ago #

    I haven't had any login problems. I deleted the plugin and changed the links, but sadly no go.

  10. Krishna

    Posted 2 years ago #

    Have you tried a manual upgrade of WordPress except wp-contents from a freshly downloaded, unedited copy of WordPress?

  11. oddmango
    Member
    Posted 2 years ago #

    Tried the manual upgrade as you suggested, no go. At this point I am just going to live with ugly permalinks. It works at least. Thank you everyone for your advice!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.