Support » Fixing WordPress » Recent post not responding to changes but others do, Plugins Error on Update

  • Plugin updates (i.e. my paid-for YouTube Pro and ) are getting “Update Failed: Could not create directory.” errors. Cannot even load “Health Check” plugin.

    On the post specified here (2018/09/20/music-simchas-2), Yoast shows an orange progress bar when populating snippet Meta description, instead of green.

    Attempting to save by selecting “Update” in Chrome for Mac returns me to “All Posts” page and no changes are found when returning to the page. On Safari, I get the browser error, “Safari Can’t Open The Page blog.veroba.net/wp-admin/post.php because the server unexpectedly dropped the connection…”

    This does NOT happen when attempting to edit my other posts.

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • “Update Failed: Could not create directory.”

    indicates you have a problem with your file permissions. check that at first.

    globalawakeningmissionaries

    (@globalawakeningmissionaries)

    My website files seem to be lost after loging in to jack plugin. How can I be helped?

    Moderator stephencottontail

    (@stephencottontail)

    @globalawakeningmissionaries: I’m not sure which plugin you’re using, but can you please make your own thread, preferably in your plugin’s support forum?

    globalawakeningmissionaries

    (@globalawakeningmissionaries)

    I used Jetpack plugin.

    globalawakeningmissionaries

    (@globalawakeningmissionaries)

    Tried installing it. Before it completed my computer went off. After reconnecting the computer, the website couldn’t get on reading “Error establishing a database connection”

    Need your help

    Thanks

    Moderator stephencottontail

    (@stephencottontail)

    @globalawakeningmissionaries: As I said earlier, can you please post your own thread in your plugin’s dedicated support forum:

    https://wordpress.org/support/plugin/jetpack/#new-post

    @danthefan, Not sure how permissions on my computer drive should make a difference, but they’re all in order. I’m no developer, but technologically adept enough to know my private internal drive’s permissions should have no bearing.
    Are you possibly referring to permissions on files stored in the account? Is there some kind of check and repair for permissions on files stored within the account, where I would think the files should be located?

    I’m referring to the file permissions on the webserver.

    Please read this:
    https://codex.wordpress.org/Changing_File_Permissions

    The Webserver-Process is owned by a system user account. The files on the webserver should be owned by that user. If not, the webserver process cannot write into these directories, hence no updates are possible.

    I’m following so far. I can only assume that, somewhere along the line, since I’m factually the only guy with access, that I must’ve changed something in my profile or added a user, so the blog is getting confused in some way.
    I have noticed a difference between my access through wordpress.com, in which it claims to have updated all my plugins, and the very different interface I see when I choose “WP Admin,” in which it claims my plugins are still not updated. Very confusing, probably because my education in WordPress is very informal and intuitive, so steps were skipped.
    I’m even having trouble conceptualizing the fact that I have fully-formatted “posts” with URLs but no “pages” on my blog site… Another topic for another day, I guess.
    I’d love to understand, also, why my WordPress.com forum account says that I created no topics. I just re-found this thread -my own thread- by using the link I received by email. Some user ID problems apparently, so I’d love to eliminate. I’d feel better if I could just find my root level account with all users in a list to define one admin and eliminate the rest without losing anything.

    @danthefan, Just looked at the link you sent me. Very PC-oriented for a Mac guy like me and I still don’t see (pardon my simplified, non-developer-oriented comprehension here) where this directory is located and how I can simply utilize some app to analyze and correct the problems.

    If there’s a way to actually enter this directory, wherever it is, and define the problem in some way or, better yet, to simply understand where the incompatibility took place… changed user ID’s, some incompatible code in the most recent post (since that post is the only one refusing to save anything), or finding the Plugin culprit preventing updates (though I trouble-shot by elimination and accomplished nothing), that’d be great.

    @danthefan OK…Forum problem solved: .org vs. com. I couldn’t be the only one confused by this.
    I prefer to seek help on the same site where my blog site account resides, so I’m taking this question there. If you can come along, great, since you’re the only one who’s cared to respond so far, but if not, then I’ll keep an eye out for your response here as well, if you have any. Thanks.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Recent post not responding to changes but others do, Plugins Error on Update’ is closed to new replies.