Support » Plugin: 2FAS Prime — Two Factor Authentication » Recent interference with WP Cerber plugin

  • kraken2k

    (@kraken2k)


    Hi,

    we’re using 2FAS Light plugin together with WP Cerber (https://wordpress.org/plugins/wp-cerber/) and until recently, we did not observe any problems. Now, the WP Cerber bypass the 2FA authentication of the 2FAS plugin (internal 2FA in Cerber is deactivated) and allows login just with password.

    I tried the solution described here https://wordpress.org/support/topic/init-action-handler-priority/ (adding define(‘CERBER_OLD_LP’,10); to wp-config.php – with proper quotation marks), but it does not make any difference. Situation is still the same and no errors in php log.

    Disbling WP Cerber plugin brings the 2FAS plugin back in action, but of course that is not the preferred option.

    Any suggestions? Thanks in advance!

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author 2FAS

    (@2fas)

    Hi,

    We know about this interference, WP Cerber introduced change in their login process in one of last updates and that’s causes this problem.
    We have an update prepared that introduces many changes but should also fix this issue. We plan to implement it this or next week.

    Thread Starter kraken2k

    (@kraken2k)

    Great 🙂 thanks a lot!

    Plugin Author 2FAS

    (@2fas)

    Hi,

    We have implemented version 3.1
    Please check that your problem has been fixed and plugin working properly.

    Thread Starter kraken2k

    (@kraken2k)

    Hi, thanks for the update! But there seems to be another problem…

    I’m unable to activate the plugin after update – the following error appears on the plugin page:

    2FAS Light plugin requirements error
    2FAS Prime plugin doesn’t work properly with the following plugins: includes.

    Plugin functionality cannot be enabled until this problem is solved. Please ask your hosting provider to support 2FAS Light plugin’s requirements.

    There is no plugin named “includes” on my website.

    • This reply was modified 9 months, 3 weeks ago by kraken2k.
    Thread Starter kraken2k

    (@kraken2k)

    After checking the PHP log, there seem to be something broken in WP Statistics plugin (https://wordpress.org/plugins/wp-statistics/). THe error seems to be referring to “wp-content/plugins/wp-statistics/includes/class-wp-statistics-schedule.php” path.

    I’m not sure if that is a broken local database of WP statistics or the plugin compatibility problem – I’ll check on it more and let here know again.

    Thread Starter kraken2k

    (@kraken2k)

    PHP errors of the other plugin are gone now, but the problem unfortunately stays :/

    I uninstalled the “WP Statistics” plugin, purged it’s tables from the database and installed it again – but after activating it, the same 2FAS light error message about “includes” plugin appears again.

    Plugin Author 2FAS

    (@2fas)

    Hi,

    Thank you for your information.
    We add script which checks potential conflicts with other plugins (when other plugin use the same 3rd party library as 2FAS Light but in another version) – then you get Fatal Error on your site.
    We fix it in version 3.1.1. Now you should get the correct plugin name with which there may be a problem.
    You can also turn off conflict checking if the plugin worked properly before.
    To do this, change constants.php file
    define( 'TWOFAS_LIGHT_CHECK_CONFLICTED_PLUGINS', true ); and set to define( 'TWOFAS_LIGHT_CHECK_CONFLICTED_PLUGINS', false );
    If the plugin works correctly, it means there is no conflict because the plugin uses the same libraries and you can copy this piece of code to your wp-config.php file so that the next time you update it does not overwrite your settings.

    Thread Starter kraken2k

    (@kraken2k)

    Hi, thank you for the fixes!

    I tried to turn the check off as you suggested and so far both plugins work as expected without any error 🙂

    EDIT: just a note to inserting the mentioned line to wp-config.php: it might not work, if you put it at the end of the file. Just put it somewhere above the this line:
    require_once(ABSPATH . 'wp-settings.php');

    • This reply was modified 9 months, 1 week ago by kraken2k.
Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Recent interference with WP Cerber plugin’ is closed to new replies.