Support » Plugin: Yoast SEO » Recent FB Crawling Problem?

  • Resolved MikeMobley2002

    (@mikemobley2002)


    Hey Guys,

    We haven’t changed anything whatsoever on our site except upgrade our plugin and now FB isn’t crawling our image on our posts at all.

    Any thoughts on this?

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 17 total)
  • jalatestuser

    (@jalatestuser)

    We are experiencing this exact same issue also.

    Jarrad

    dziudek

    (@dziudek)

    Hi,

    My friend had a similar problem and solution was easy – disable HTML compression in W3 Total Cache.

    In my opinion a reason of the issue are metatags splited into two lines:

    <meta
    content="..." />

    I suppose that Facebook crawler is not supporting newline chars inside the metatags 🙂

    ilovefridays

    (@ilovefridays)

    Hi

    We’re having the same issue.

    I put my URL into here: https://developers.facebook.com/tools/debug/

    My URL: https://www.1africa.tv/what-frustration-does-to-your-future/

    And it says:
    Inferred Property:
    The ‘og:image’ property should be explicitly provided, even if a value can be inferred from other tags.
    Missing Properties:
    The following required properties are missing: og:url, og:type, og:title, og:image, og:description, fb:app_id

    From the website:
    <!– This site is optimized with the Yoast SEO plugin v5.4 – https://yoast.com/wordpress/plugins/seo/ –>
    <title>What frustration does to your future | 1Africa</title>
    <meta name=”description” content=”No matter how you encounter frustration – and there is no doubt you shall – it can be a powerful conditioner for your soul.”/>
    <meta name=”keywords” content=”career satisfaction, inner health”/>
    <link rel=”canonical” href=”https://www.1africa.tv/what-frustration-does-to-your-future/&#8221; />
    <meta property=”og:locale” content=”en_US” />
    <meta property=”og:type” content=”article” />
    <meta property=”og:title” content=”What frustration does to your future | 1Africa” />
    <meta property=”og:description” content=”No matter how you encounter frustration – and there is no doubt you shall – it can be a powerful conditioner for your soul.” />
    <meta property=”og:url” content=”https://www.1africa.tv/what-frustration-does-to-your-future/&#8221; />
    <meta property=”og:site_name” content=”1Africa” />
    <meta property=”article:publisher” content=”https://www.facebook.com/1AfricaOnline&#8221; />
    <meta property=”article:author” content=”https://www.facebook.com/davidjeremywebster/&#8221; />
    <meta property=”article:tag” content=”Frustration” />
    <meta property=”article:tag” content=”hope” />
    <meta property=”article:tag” content=”lifestyle” />
    <meta property=”article:tag” content=”practical thinking” />
    <meta property=”article:section” content=”Career” />
    <meta property=”article:published_time” content=”2017-09-18T11:00:32+05:30″ />
    <meta property=”article:modified_time” content=”2017-09-18T15:50:23+05:30″ />
    <meta property=”og:updated_time” content=”2017-09-18T15:50:23+05:30″ />
    <meta property=”og:image” content=”https://www.1africa.tv/wp-content/uploads/2017/08/frustration.jpg&#8221; />
    <meta property=”og:image:secure_url” content=”https://www.1africa.tv/wp-content/uploads/2017/08/frustration.jpg&#8221; />
    <meta property=”og:image:width” content=”1000″ />

    Mike

    jalatestuser

    (@jalatestuser)

    Have disabled HTML compression in W3 Total Cache and can confirm that this temporary solution works. It’s not ideal though as now the code is not minified.

    Looking forward to Yoast SEO providing a permanent solution.

    J>

    Plugin Support monbauza

    (@monbauza)

    @mikemobley2002 We reviewed the source code of some of your posts and notice another plugin/theme is inserting Open Graph tags too (see screenshot). This may cause problems when you share your posts on Facebook. We recommend you remove the tags that are not inserted by Yoast SEO.

    @ilovefridays We ran your post through the Facebook Debugger (using the “Scrape Again” option) and the right information seems to show up. If you’ve updated your social settings or metadata for an article and aren’t getting the right details in Facebook yet, you might need to force update Facebook’s cache of that page. To do that, go to the Facebook debug tool and enter the URL you wish to update. After that you should be ok.

    @jalatestuser This problem doesn’t seem to be caused by Yoast SEO as the plugin outputs the meta tags correctly. It’s only when you enable HTML compression that your source code changes and Facebook can’t parse the meta tags correctly.

    Bojan

    (@bojanbilly)

    Hi!
    I have similar problem.
    All previous posts and pages shared to Fb correctly, with proper featured image and stuff, like this one http://astroriznica.com/o-suncu-corpus-astronomiae/
    Few days ago I tried to share newly posted text http://astroriznica.com/o-veneri-corpus-astronomiae/ but there is no featured image. I tried everything, nothing helps. Apparently width and height are missing. But for old posts nothing is missing
    property=”og:image:width” content=”754″ /><meta
    property=”og:image:height” content=”356″ /><meta

    I’m very confused.

    Thanks in advance,
    Bojan

    • This reply was modified 3 years ago by Bojan.
    ilovefridays

    (@ilovefridays)

    @monbauza
    thank you for the reply, however the only way we were able to get the post to display correctly in FB was to disable Minify in W3 Total Cache. You probably checked the post after we had disabled it, hence it worked. I had already scraped the post using FB Debugger.. many times. I still do believe there is a an issue with Yoast plugin since latest update.
    Kind reagrds

    trainingday

    (@trainingday)

    I can confirm that disabling the Minify HTML setting in W3 Total Cache works as a TEMPORARY fix. However, I have had this setting ON for years and it worked fine together with Yoast SEO. Only when I updated to 5.4.0 I ran into this problem… Yoast, can you please look into this!! Thank you!

    Bojan

    (@bojanbilly)

    Me too. I disabled HTML minify and it worked. Thanks everyone!

    Plugin Support marcanor

    (@marcanor)

    @trainingday Since the Yoast plugin is outputting the correct tags in the source, and the issue only occurs when Minify is enabled in your caching plugin, this cannot be considered a Yoast plugin issue.

    trainingday

    (@trainingday)

    That is really weird, since the problem surfaced when I updated Yoast Seo, not when updating W3 Total Cache… I haven’t touched W3TC and it’s configuration for quite some time, so I am positive it has nothing to do with W3TC. Can I safely revert to a previous version of Yoast Seo to validate my point?!

    jalatestuser

    (@jalatestuser)

    Hi @monbauza. Can you please confirm that Yoast SEO is incompatible with W3 Total Cache.

    Looks like with the latest update of 5.5 for Yoast, the problem is now solved. Is it solved now for all of you?

    @mikemobley2002 thank you for that hint! Yes indeed, after upgrading to 5.5. I can confirm the error is gone. I can activate W3TC minify again and all schema markup is visible and valid again. So this problem had nothing to do with W3 Total Cache @marcanor

    Hi @monbauza and @marcanor
    I would really need your help. I have this site: https://viagensdestinos.com
    Since a few days ago, Open Graph Debugger doesn’t show the Facebook image I selected for each post (in fact it doesn’t show any picture at all).
    I see this warning: The following required properties are missing: fb:app_id
    I didn’t have any facebook app, and I didn’t need one, but I created one anyway and added it on the facebook tab of Yoast Plugin. But Open Graph Debugger keeps showing a blank image… Can you help me?

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘Recent FB Crawling Problem?’ is closed to new replies.