Support » Plugin: Contact Form 7 » reCAPTCHA v3

  • Great plugin @takayukister.

    Because, reCAPTCHA v2, is passing too many spam emails, and Google introduces reCAPTCHA v3 Beta. Are you planning to integrate this before the final release of Google ? We already can generate the keys to reCAPTCHA v3, but obviously right now they not working without the plugin update to support them.

Viewing 15 replies - 16 through 30 (of 31 total)
  • RafaelDeJongh

    (@rafaeldejongh)

    Thanks for integrating ReCaptcha in the new v3 version. It seems to work (I had no problem by submitting my own feedback formular).

    But now the ReCaptcha badge (logo with actions, bottom right) appears on every page on the site, not only on the feedback formular page. This is a little bit too much for me, I’m sorry. And it’s not necessary to include the JavaScript code on all pages. Would it be possible, or do you plan to change this behavior?

    Thanks in advance,
    Kind regards,
    Ralf

    seanwebb68

    (@seanwebb68)

    Thanks for integrating ReCaptcha in the new v3 version. It seems to work (I had no problem by submitting my own feedback formular).

    But now the ReCaptcha badge (logo with actions, bottom right) appears on every page on the site, not only on the feedback formular page. This is a little bit too much for me, I’m sorry. And it’s not necessary to include the JavaScript code on all pages. Would it be possible, or do you plan to change this behavior?

    Thanks in advance,
    Kind regards,
    Ralf

    Yeah i have notice the same issues and would like a resolution if possible

    Chuckie

    (@ajtruckle)

    I use:

    body:not(.page-id-833) .grecaptcha-badge {
      bottom:65px !important; 
      display: none;
    }
    mediafluent

    (@mediafluent)

    Thanks for the implementation and the resolution. Does that go under the additional settings tab of the page ID or the site css or page css?

    Chuckie

    (@ajtruckle)

    Appearance / Customize / Additional CSS.

    mediafluent

    (@mediafluent)

    I have multiple pages with CF7 forms. Cannot figure out the code for more than one page ID. This breaks it–

    body:not(.page-id-833 .page-id-944)
    .grecaptcha-badge {
      bottom:65px
     !important;
      display: none;
    }
    Chuckie

    (@ajtruckle)

    Glance the other issues in this forum.

    Some of them provide the syntax for multiple pages.

    Also, some of them explain how to use a second plugin to use v2 again. πŸ˜€

    RafaelDeJongh

    (@rafaeldejongh)

    @mediafluent

    You aren’t supposed to do it like that, read the information about the :not() selector here: https://developer.mozilla.org/en-US/docs/Web/CSS/:not

    In general this should work:

    body:not(.page-id-833):not(.page-id-944) .grecaptcha-badge{display:none}

    DO NOTE HOWEVER that the code and javascript requests and actual security IS STILL PRESENT on every page! It is better to exclude the JavaScript and CSS files being added to each site by CF7 to exclude those all together. This can be easily done via some PHP in functions.php or by a plugin manager where you disable the plugin everywhere else other than the specific urls you want. For example Swift Performance or so.

    As far as I’ve read the badge isn’t required to be on the page, what is HOWEVER is that you need to provide proper information in your privacy policy AND that they do need to accept via a checkbox with the privacy policy + privacy policy/cookie policy bar that your users are fine that such data and cookies are being placed on the users pc.

    Just make sure everything GDPR wise is in order!

    Chuckie

    (@ajtruckle)

    I am using this plugin:

    https://wordpress.org/plugins/advanced-nocaptcha-recaptcha/

    No more v3. πŸ‘

    I need help! I cannot log in to my site because of the following:

    1. I installed v3 recaptcha on my site
    2. I entered v3 recaptcha info. (keys) on my site
    3. I deleted the v2 recaptcha keys from Google, thinking I no longer needed them.
    RESULT: I cannot log in – recaptcha gives wrong version error. I was also BLOCKED from logging in due to several attempts.
    4. I requested and have NEW v2 keys from Google for the site, but I need to to install them in order to be able to successfully log in.

    How do I fix my problem?

    @rootsdigger05

    Rename the plugins via FTP, contact form 7 and any plugin that might lock you out. If it’s a server side lockout, contact your server provider.

    I got so many spam contacts these days after upgraded it to v3.

    I was able to fix the problem. Long story short, I reverted back to reCaptcha V2 for my login and registration forms and they both work fine now. The only form I had to leave on reCaptcha V3 was my Contact Form 7 submission form.

Viewing 15 replies - 16 through 30 (of 31 total)
  • The topic ‘reCAPTCHA v3’ is closed to new replies.