Support » Plugin: Contact Form 7 » Recaptcha v3 script is being added to all pages

  • Forcing the upgrade to Recaptcha v3 seems highly unproductive.

    Now we have the Recaptcha script being added to ALL PAGES on our website. We don’t want the pesky bottom-right sticky logo on every single page of our website. You really think Google doesn’t have enough data on our visitors already that you want to help them track everyone everywhere?

    That’s great advertising for Recaptcha, but interferes with our user experience and is an horrible eye sore.

    We’ve been using the wpcf7_load_js hooks for years to add Contact Form 7 script ONLY on contact pages, but your integration of Recaptcha v3 doesn’t respect it and is being added everywhere.

Viewing 10 replies - 16 through 25 (of 25 total)
  • @paul_g_787 I’d personally recommend using the workaround from @lofesa rather than reverting the plugin version to something other than current. Nice to have that option outlined as well, though.

    Although that fixes the icon it does not stop the new tracking and allows Google to track all of your visitors.

    Oh and also, not displaying the reCaptcha v3 badge is against the reCaptcha terms of service unless you tell your visitors by some other means Google is tracking them.

    The workaround from @lofesa still shows the badge on pages where the form is shown and reCAPTCHA is being used. It just makes it so it doesn’t show the badge on every page of the site regardless of whether a form is even present or not.

    Yunis777

    (@yunis777)

    Hi,

    I resolved the problem after reading and acting upon the advice in the following two support questions:
    https://wordpress.org/support/topic/how-do-i-hide-recaptcha-v3-badge/
    https://wordpress.org/support/topic/annoying-floating-recaptcha-box/

    I proceeded to add the following CSS code in the customizing section of my theme:
    /*—Hide reCaptcha v3 visible seal—*/
    .grecaptcha-badge {
    opacity:0 !important;
    }

    “display:none” should NOT be used because it DISABLES the spam checking!

    I then added the following statement at the bottom of the form as explained by the user NightL:
    “This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.”

    Regards,

    Yunis

    KZeni

    (@kzeni)

    @yunis777 Setting the opacity of the badge to 0 is effectively not displaying the badge as necessary through the reCAPTCHA policy. This is not correct! This is a failure in following policies outlaid by the providers of the service you’re utilizing when suitable alternatives are available.

    Do what @lofesa proposes (see: https://wordpress.org/support/topic/recaptcha-v3-script-is-being-added-to-all-pages/#post-10983560) instead to not break the reCAPTCHA policy as well as only displaying the badge on pages containing the form (as necessary per reCAPTHCA’s policies and therefore laws governing the behaviors of your site!)

    Honestly, everything I’ve seen proposed after @lofesa is either flawed in following the policies of reCAPTCHA (and the laws they’re abiding by) or aren’t otherwise best practices. What @lofesa has already provided is a totally reasonable solution to the issue without failing in those key areas.

    Yunis777

    (@yunis777)

    @kzeni

    How and where do I insert the code @lofesa suggests in the WP dashboard? I’m unfamiliar with PHP code and don’t want to risk breaking my site.

    Regards,

    Yunis777

    KZeni

    (@kzeni)

    You’d want to add it to your theme’s functions.php file by editing the theme. That said, this can break your site if done improperly (which may break the site admin making it so FTP access is necessary to update the file to resolve any potential issues.)

    If you really don’t want to deal with this implementation, then I’d suggest disabling the reCAPTCHA integration with Contact Form 7 and then re-implementing it with the CF7 integration https://wordpress.org/plugins/invisible-recaptcha/ provides. This is a code-free option which follows the reCAPTCHA requirements and still only shows the badge on pages containing a form (not every single page).

    Not using CF7 came with my theme – so just disabled and deleted it still have that annoying logo that leads to Google privacy pages instead of mine.

    I use the plugin CleanTalk – do not need a captcha ….. grrrrrr

Viewing 10 replies - 16 through 25 (of 25 total)
  • You must be logged in to reply to this topic.