Support » Plugin: Contact Form 7 reCAPTCHA Extension » Recaptcha v3 not working so well

  • mcmas

    (@mcmas)


    Hiya

    I’ve upgraded the Google recaptcha keys for my websites to version 3 and installed them in the ‘Contact Form’ – ‘Integration’ section. With the v2 keys, I never got spam from my contact forms. Now, the spam is starting to flow. I look after about 60 websites for myself and my clients. None of us will be happy if we get daily spam.

    How can we tighten the security? And solve this problem?

    Thanks!

    Mcmas

    • This topic was modified 12 months ago by mcmas.
Viewing 15 replies - 16 through 30 (of 30 total)
  • mdsheeks

    (@mdsheeks)

    Nice, now I have a recaptcha widget displaying on all my pages. Just what I wanted.

    Same problem.

    Someone has figured out how to defeat recaptcha in contact-form-7. Could the authors please fix this? Thanks.

    Same problem here, after upgrade to Contact Form 7 5.1 and recaptcha v3 spam is passing.

    BRING BACK V2 OPTION [waves pitchfork]

    Yup, doesn’t work at all – lots of spam.

    I think there’s more to installation than simply the API Keys.
    Something about adding stuff to certain HTML headers and JavaScript files?
    And then there’s a background learning curve/spam rating thing?
    No thanks. I just want to install, hit go and be relatively spam free. I would imagine I’m not alone…

    If anyone needs a temporary solution use the WP Rollback plugin to roll CF7 back to 5.0.5, then add your V2 keys back to the integration section and V2 recaptcha will return.

    mtm

    (@flatpack-music)

    +1 on this issue for me, too. several clients suddenly asking why they’ve started to receive spam again.

    will be rolling back in all cases but this isn’t a long term solution. please advise.

    Following up…I decided not to wait or try the various “fixes” posted on other threads and forums.

    I ended up deleting Contactform 7 from all of the sites I manage and installed the free version of WPForms:

    https://wpforms.com

    WPForms can still utilize reCaptcha v2, both “Checkbox” and “Invisible”.

    The free version of WPForms is still pretty robust and the resulting email messages are much nicer.

    I’ve tried WPForms in several configurations and all have worked flawlessly so far. They even offer info for some “hacks” like adding the sender’s IP address, etc.:

    https://wpforms.com/web-form-hacks-to-unlock-customer-data/

    I’ll post back if there are any issues or if the clients start receiving spam, but so far so good.

    Joe

    (@jwdevelopment)

    Hi,

    Seems we are all having the same issue here – I’d rather not convert forms to another plugin or revert the plugin, but there needs to be a solution from the plugin author soon, because I’m getting tired of the spam.

    Surprised they haven’t commented here yet, even acknowledging it’s an issue to be looked at.

    Same here. Updated to Contact Form 7 vs 5.1 and changed to Google reCaptcha v3. Spam on one form was instantaneous and a lot!

    Anyone know if its an issue with reCaptcha V3 itself or the plugin?

    It looks like the forms are being submitted even if the recaptcha was not passed.
    I logged some of the entries to figure out what was happening, it seems like when someone passed the recaptcha, the field [g-recaptcha-response] from WPCF7_Submission::get_instance() get_posted_data() is present, for the spammy submissions, it’s not.

    I now hook into the wpcf7_before_send_mail action to ignore the submissions that don’t have this field populated. Seems pretty easy for the plugin maintainers to fix, but this works for now.

    • This reply was modified 11 months, 3 weeks ago by quodlibet.

    Hi @quodlibet,

    Can you elaborate more on your solution? Is it easy enough to implement the temporary fix for not savvy developers?

    I’ve spoke too soon, before checking in the logs, the spam amount seems to be down since the update 5.1.1.

    The only issue that remains is that the recapcha logo is displayed in the bottom right corner of every page.

    • This reply was modified 11 months, 2 weeks ago by gargoyle82.
    luzzy

    (@luzzy)

    Just add the following to your css:

    .grecaptcha-badge {
    display: none;
    }

    mtm

    (@flatpack-music)

    Yes – the spam filters are now working again after the last update, so all is pretty much well. Be aware though that whilst @luzzy’s CSS will work there are certain conditions we are contractually bound to meet if using recaptcha. If you hide the logo in the bottom corner be sure to add in the necessary legal text somewhere logical:

    This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

    See the Google policy FAQ here.

    • This reply was modified 10 months ago by mtm.
Viewing 15 replies - 16 through 30 (of 30 total)
  • The topic ‘Recaptcha v3 not working so well’ is closed to new replies.