Support » Plugin: Contact Form 7 » recaptcha v3 not working

  • Resolved watermarkbs


    I upgraded this site to v3 and the form stopped working. Error is ‘message not sent, try to contact administrator another way.’

    I have read thru the support forums and tried the following (all with no success):
    create new v3 keys (twice)
    go back to v2 keys
    try switching to WP default theme
    deactivated every other plugin one by one and tested contact form

    When I put the v3 keys in it is working correctly because the recaptcha popup is on the bottom of all pages. The only way to get the form to work is to deactivate recaptcha.

    Side note…I have Contact Form 7 with recaptcha on 4 other sites with no issues.

    Please help!

    • This topic was modified 4 months, 1 week ago by watermarkbs.

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Takayuki Miyoshi


    I’m not sure why you directed me to that link because I said I’ve already tried everything.

    Nothing is working.

    Can you help in any other way?

    Or do I need to just stop using CF7 for this site? I really don’t want to because, like I said, I have been using CF7 on multiple sites for many years and really like it.

    Plugin Author Takayuki Miyoshi


    If you are still interested in resolving this issue, just read it.

    I have. 3 times. I started this whole process a few weeks ago by following the instructions on that post. Twice. And then I did it again this morning a third time.

    Are you telling me I need to do it a fourth time?

    Are you telling me I need to do it a fourth time?

    No – you just need to do it correctly once.

    Why the rudeness? I am just asking for help.
    And in reading the posts in the forums over the past few days, I am by far not the only one with this issue.

    Can anyone offer any HELPFUL advice?

    • This reply was modified 4 months, 1 week ago by watermarkbs.


    I have exactly the same problem. I have read all the advice and nothing. On other my websites it works without a problem and one does not work. Recaptcha I have well configured.



    I have a solution!

    This is probably the best solution (before the 5.1 version of the plugin was released on December 18). It allows you to keep Contact Form 7, but also use the V2 methodology. Here are the steps for implementation:

    Add and activate this plugin
    Go to the settings of the new plugin and insert the Google ReCaptcha V2 keys (you can also edit other settings there)
    Remove any v3 Google keys from Contact Form 7 > Integration and remove the Contact Form 7 shortcode [recaptcha]
    Add the shortcode [anr_nocaptcha g-recaptcha-response] that is supported by the new plugin and save the form.



    Just wanted to say that I’ve had this problem for a while now too with Recaptcha v3. I originally thought I had some other problem with my theme or php installation or something because the contact forms just wouldn’t work. After fiddling with things, and turning off recaptcha though, they immediately started working.

    Worth noting that they were working for quite some time without me changing anything. I don’t know what Google or other WordPress update may or may not have caused the new failure. Would love a solution that doesn’t require me to go to a previous version of the plugin or old recaptcha system



    Agreed @mulicheng!

    Thank you for your helpful suggestion @atgpoland, very much appreciated. I did try going back to v2. I would like to use v3 just for security reasons, but am unable to.

    Hopefully someone (Google, WP or CF7) will come up with a fix soon!



    Just wanted to close this loop and say that @atgpoland…your solution worked!! I tried to just use another form plugin, but none of them did all that my client wanted.

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.