Support » Plugin: Contact Form 7 » reCAPTCHA v3 causes error message

  • Resolved govus

    (@govus)


    Hello! Having problems with reCAPTCHA v3. I’ve tried this with two different sites with different themes and hosting and both contact forms work without recaptcha, but also both give the “There was an error trying to send your message. Please try again later.” with reCAPTCHA.

    I read somewhere that with CF7 I must use v3, I’ve generated the site key & secret key and integrated them to the forms but no luck so far. I also tried v2 but couldn’t get the checkbox to display either. I didn’t really find solutions when searching myself… Any help is greatly appreciated, thanks! :–)

    • This topic was modified 7 months, 3 weeks ago by  govus.
Viewing 3 replies - 1 through 3 (of 3 total)
  • I am having the same exact problem with my site. Please help!!!!

    Hey you both,

    I have the same or a similar problem.

    One solution helped me one step further:

    1. Go to https://www.google.com/recaptcha/admin
    2. Open the Settings of your v3 API Account
    3. At the Domains option, only put in your domain “example.com” no www. or anything in front.
    4. Save and wait a moment… ๐Ÿ™‚

    Tell me if this worked for you!

    With best regards from germany,
    Dom

    @domheinzde That worked for me! Not having http://www. was the answer. However, recaptcha v3 adds a badge to inform the visitor about it, so I had to hide it with css:

    .grecaptcha-badge {
    visibility: hidden;
    }

    It seems this is allowed, as long as you add the text โ€˜This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.โ€™

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘reCAPTCHA v3 causes error message’ is closed to new replies.