WordPress.org

Forums

WP-Members
[resolved] reCAPTCHA Stops All Emails to New Subscribers (but not to admin) (5 posts)

  1. sassymonkey
    Member
    Posted 1 year ago #

    I'm using latest 2.9.0 of WP-Members and can't get any emails to be sent to new subscribers when reCAPTCHA is enabled (also was happening in the previous 2.8.10 version).

    It's not a wp_mail issue as the admin notification is sent and if I create a new profile from the Users section of the WP admin, it sends the emails to the new user fine.

    When I deselect the reCAPTCHA checkbox in the WP-Members Options screen, everything works perfectly. If I check the box again, no go.

    Any ideas on how to fix this? Overtime, this prominent form is going to be a big spam magnet so I'd love to find a fix.

    http://riverviewhomeowners.com/members/sign-up/

    https://wordpress.org/plugins/wp-members/

  2. Chad Butler
    Member
    Plugin Author

    Posted 1 year ago #

    It's not a wp_mail issue as the admin notification is sent and if I create a new profile from the Users section of the WP admin, it sends the emails to the new user fine.

    Actually, it may or may not be wp_mail issue. The fact that it sends the two emails when you have disabled reCAPTCHA is probably coincidental, as the sending of email on a successful registration and displaying/validating reCAPTCHA are not related.

    Also, "sent" does not equate to "received" when troubleshooting email issues. Even if wp_mail sends a message, it could get stopped by your host or the receiving host before it ever gets to the inbox. And just because one particular email goes through ok does not mean that others will. There are a number of possible reasons for that.

    The first thing you need to know is if your host throttles emails. When you have a new registration with admin notification, two emails are sent at the same time. Some hosts might throttle this.

    I would suggest also filtering the "from" headers and use an address that your host recognizes as valid (i.e. it comes from the same domain). There is a filter hook for that.

    I have a general post here with information regarding troubleshooting wp_mail, some things you can do to make your sending more reliable, and also how to set up SMTP (which is the best thing you can do).

  3. sassymonkey
    Member
    Posted 1 year ago #

    Looks like when I posted last night, I got that common 500 error and when I refreshed it seemed to have double-posted.
    ____

    I'm positive my mail host is not scrubbing emails. Two reasons: I'm using two different hosts with four different domain names and received none of the emails in any case while reCAPTCHA is on. Also, I tested sending emails from my desktop and phone mail apps to all addresses using the same from address that WP is set to and always received mails. I'm pretty sure my hosts are not the problem.

    As to host throttling because of two quick messages being sent, then I would not have received messages when I turned off reCAPTCHA. But, again, that's when everything works fine.

    SOLUTION
    The answer seems to be in using an email address that matches the current domain name in the WP Settings > General > E-mail Address field. I also used that address in the WP-Members > Emails > Set a custom email address field.

    Everything seems to be working perfectly WITH reCAPTCHA enabled.

  4. sassymonkey
    Member
    Posted 1 year ago #

    As a minor note: I tried using [blogname] in the Set a custom email name field and it did not trigger the blog's title in the emails sent. It just relayed "[blogname]" in the from field for the message. This seems like a bug especially since directly above there's a suggestion to use these shortcodes.

    I want to stress though that this plugin is really well done and is working wonderfully! I always expect huge technical and functional problems with more complicated plugins like this, but that's not the case with WP-Members. It's well conceived and details have been nailed for a great overall experience. Well done on a complex project, Chad!

    Also, thanks for the thoughtful help response here too.

  5. Chad Butler
    Member
    Plugin Author

    Posted 1 year ago #

    Glad you have it working the way you want. And thanks for the kind words and review. That's always appreciated.

    On the shortcode, you actually can't use them in the email address and email name. So it's not really a bug but rather that I probably need to reword or display that info differently.

    The shortcodes are for the subject and the body of the emails. I probably should change the line to "customize the subject and body of the emails" and/or swap places with the email address settings.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP-Members
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags