Support » Plugin: Contact Form 7 » reCAPTCHA Stopping Form From Working

  • Hello, so it has been brought to my attention that the contact form has stopped working. I checked MX Records, configured SMTP plugin and checked plugins etc, but the enquiry form still doesn’t work and gives me the orange border error message (span)

    I have however discussed if I remove the reCAPTCHA v3 keys, the form does work. Anybody got any advice on this? How do you set up reCAPCTHA keys so they work correctly? I have tried a bunch of different settings.

    Thanks, Tom

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Takayuki Miyoshi


    What other plugins and theme do you use on the site?

    Thread Starter tomsenior856


    Hi @takayukister

    The Theme I’m using is Avada
    Plugins – CF7 Smart Gride Extentsion, Classic Editor, CF7, Cookie Notice, Favicon RealFavicon Generator, Flamingo, Fusion Builder, Fusion Core, Jetpack, MonsterInsights, SG Optimizer, Wordfence Security, WP Mail Server, WP Rocket, Yoast SEO

    Same issue with me with google capcha form is not working

    • This reply was modified 1 year, 1 month ago by Murad Khan.

    This is also occurring for me. It appears submitting the form a second time completes successfully. It looks like there may be an issue with the reCAPTCHA integration.

    I had the same issue with reCAPTCHA V3. It would work most of the time, but it did clock up a lot of false positives spam detection incorrectly, which was very frustrating. I changed back to reCAPTCHA V2 and haven’t had an issue with it since. I know V2 can show the image puzzle, but it works for me every time.

    @conor_hyland thanks for the tip. Is there a way to use v2 with the latest version of Contact Form 7, or do I have to revert to an older version of the plugin?

    You can still use the latest version of Contact Form 7. In the interim I’m using the plugin “ReCaptcha v2 for Contact Form 7”. You need V2 keys though obviously. Also install Flamingo. It will show you what module is reporting it as spam and show you the score. I’m using Flamingo to monitor and since changing to V2, all is perfect so far. Let us know how you get on.

    @muradgull, @jayzinn & @conor_hyland – see I have the same problem! Can I just reply to someone else’s post with “Me too”?.

    If you are willing to create a new question, which details your issues, somebody will likely be able to help you there.

    I have the same issue, since last night. Deactivated Recaptcha and everything works like a charm again.

    I used a custom theme. Plugins:
    Akismet Anti-Spam
    Classic Editor
    Contact Form 7
    Cookie Notice
    Core Control
    Google Analytics Dashboard for WP (GADWP)
    WP Rocket
    Yoast SEO Premium

    Same problem with a site I manage.
    If just click on Send more often the message is sent after the second, third, fourth, … time.

    Theme Used:Sydney Pro

    Plugins (active):
    Contact Form 7 5.1.6
    Contact Form 7 Widget For Elementor Page Builder 1.0.9
    Elementor 2.8.5
    Flow Paper 1.9.2
    Honeypotfor Contact Form 7 1.14.1
    Polylang 2.6.9
    Realy Simple CPATCHA 2.0.2
    Really Simple SSL 3.2.8
    Redirection 4.6.2
    Smart Slider 3 3.3.26
    Social Icons Widget by WPZOOM 3.4.2
    Sydney Toolbox 1.0.8
    WF Cookie Consent 1.1.4
    WP Mail SMTP Plugin by Mail Bank 4.0.10
    WP Migrate DB 1.0.11
    YOAST SEO 12.9.1

    Plugins (inactive):
    Crelly Slider 1.3.6

    Help with the problem is very welcome.




    Same problem. Disabled Captcha integration & it started working again. Tried to use the Advanced noCaptcha & invisible captcha plugin instead but that caused a yellow-border validation notice.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘reCAPTCHA Stopping Form From Working’ is closed to new replies.