Support » Plugin: Caldera Forms Anti Spam » reCaptcha not working, giving error message

  • Resolved RedirDom


    Each time a user tries to submit the form receives an error messages that says “The captcha wasn’t entered correctly. Reset.”
    The reset button brings you back to the form, and does nothing. any idea how to solve this issues?

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Andrew Lima


    Hi @redirdom

    Thanks for using Caldera Forms Anti Spam.

    I noticed you are using V3 reCAPTCHA, are you still experiencing issues with your form?

    I’m having the same issue as the topic starter.

    It only occurs when user is more then two minutes on the page where the form is used. Which is caused by the fact that the reCAPTCHA token is already requested and expired. This token is only valid for two minutes after requesting one.

    It can be solved by requesting this token when the user hits the submit button.

    Hope that this can be solved soon as I had to disable it on multiple websites 🙁

    Plugin Author Andrew Lima


    Thanks for the feedback @rbonk, I’ll try work on recreating this and leave the page open for > 2 minutes.

    I’ll post here if there are any news/updates.

    @andrewza do you already have any clue when this issue will be solved?

    I have a ticket open that I think identifies the issue & offers a solution.

    It has some pretty big changes & is only heavily tested against v3, so I suspect it’ll take Andrew some time to feel comfortable merging it in.

    Plugin Author Andrew Lima


    Thanks @ecaron, we had to attend to another bug and released V0.3. I’ll be looking at your Pull Request – Thanks so much for contributing and understanding these things take time! 🙂

    That bug that warranted the v0.3 release really caught me by surprise, too.
    The PR has been submitted – We’ve been using it in production for a couple days and our complaints about “forms not able to submit” has dropped to zero.

    I debated on applying the CodeSniffer adjustments to the entire plugin, but I figured that’d make the diff harder to run. Once/if this PR gets approved, I’ll follow it with another CodeSniffer ( PR that has no changes to functionality – if you don’t mind.

    Plugin Author Andrew Lima


    I am keen to get this merged in and agree the code could use WPCS.

    Hi there,

    I just received word from a client that a customer was unable to submit a form with the V3 captcha – getting the same error that the captcha was not entered correctly.

    I was only able to recreate the issue when the form was open more than 2 minutes. I see y’all are working on this (very cool, btw!). Is there an ETA for a fix?

    Should I downgrade to ReCaptcha V2?


Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘reCaptcha not working, giving error message’ is closed to new replies.