• Resolved jimmiedee

    (@jimmiedee)


    Hello,

    Recaptcha has stopped working on my contact form. Something has changed but I do not know what it is.

    I have read through other support requests on this.

    I have tried non-conflict mode – no difference.
    I have checked my footer – it is correct.

    I have tried the invisible version and the checkbox version. Both state “reCAPTCHA is required.”

    Any clues?

    Thanks,
    Jimmie

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Support Ethan Choi

    (@ethanchoi)

    Hi jimmiedee,

    It is likely that reCAPTCHA is getting loaded twice on the page — once by WPForms, and once by either your theme or another plugin, and this causes the error in the form.

    To resolve this, you can track down what’s generating the other reCAPTCHA code and, if possible, turn it off.

    In case it help, we have a guide on how to test for plugin or theme conflict, which could help narrow down the other reCAPTCHA code.

    I hope this helps 🙂

    V.E.L

    (@vezraimanuel)

    Hi @ethanchoi, I hope it’s okay for me to reply here 🙂

    Hi @jimmiedee, I encountered same problem before and it was solved, perhaps I can share something here, hopefully can help you narrow down the issue 🙂

    as @ethanchoi already explained, reCAPTCHA loaded twice. And from what I’ve seen, the first one is loaded by your Jetpack sharing addon (sharedaddy?) (please correct me if i’m wrong). And it is used by sharedaddy for email sharing (email sharing button on your article)

    This is the code loaded by Jetpack:
    <script type="text/javascript" src="https://www.google.com/recaptcha/api.js?hl=en_GB" async>

    And this is the code loaded by WPForms:
    <script type='text/javascript' defer='defer' src='https://www.google.com/recaptcha/api.js?onload=wpformsRecaptchaLoad&render=explicit'></script>

    You can start testing by first disabling the sharedaddy feature on your Jetpack, as mentioned here. It might disable the reCAPTCHA. And if it’s right and the WPForms is working, I would suggest to use another sharing plugin rather than the sharedaddy feature from Jetpack.

    I hope this is useful 🙂

    Thanks guys!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Recaptcha not working’ is closed to new replies.