Support » Plugin: Contact Form 7 » reCAPTCHA Not Working

  • fatkinson

    (@fatkinson)


    I cannot get reCAPTCHA to work on Contact Form 7.
    The reCAPTCHA button does not even show up on the form editor.
    My hosting provider says that GD is installed on the Web server but FreeType library is not. They do not plan to install it.
    Is this the reason I can’t get it to work?

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 17 total)
  • linux4me2

    (@linux4me2)

    I suspect that if you don’t see the reCAPTCHA button on the form editor, you are using version 5.1 or 5.1.1 of CF 7. Those versions of CF 7 use Google reCAPTCHA v3, which does not require the reCAPTCHA tag in your forms. There’s no use for the reCAPTCHA button in the form editor anymore because it isn’t used. In fact, if the reCAPTCHA tag is in your form, v. 5.1 will remove it.

    All you need to do to use reCAPTCHA v3 in your forms is make sure you have entered new, Google v3 reCAPTCHA keys on the Integration page of CF 7. V2 keys won’t work with v3. Complete instructions can be found here.

    Once you have it set up, if you see the Google reCAPTCHA badge in the lower-right corner of every page of your site, you know it’s working. There will be no checkbox or user interaction required.

    designernotacoder

    (@designernotacoder)

    I have the same issue. Yes, I did update Contact Form 7 and yes, I did create a new V3 site key. yes, I did remove the reCaptcha tag in my form.

    Yet it still says “There was an error trying to send your message. Please try again later.”

    what could be the problem? Do I need to add client or server side integration settings?

    linux4me2

    (@linux4me2)

    @designernotacoder: No, the client and server side integration are done by CF 7, they are included on Google’s page for people who are integrating Google reCAPTCHA v3 on their sites by coding it themselves. All you should need to do is add the site and secret v3 keys you created on Google’s site on the Integration page of CF 7 in the WP admin according to the instructions I linked to above.

    If, after doing that, you see the Google reCAPTCHA badge on all your pages, it is active. If you don’t see the badge, you might check your browser’s console to see if there are any javascript errors that could be preventing the code from running.

    designernotacoder

    (@designernotacoder)

    @linux4me2: I did enter the site key and the secret key on the Contact > Integration section of the dashboard.

    I do have many blocking extensions on my Chrome, but I tried it in Safari and Firefox and I am getting the same result “There was an error trying to send your message. Please try again later.”

    I know you are saying that it should work, but that is why I’m here in this forum. It is not working as described in the instructions…that I clearly followed.

    Do you have any other idea why this is not working?

    designernotacoder

    (@designernotacoder)

    Also, I am not seeing any badges of any sort on any browser or any page on my site. What badge are you referring to?

    designernotacoder

    (@designernotacoder)

    Here is the console:

    jquery.mCustomScrollbar.min.js:8 A parser-blocking, cross site (i.e. different eTLD+1) script, http://cdnjs.cloudflare.com/ajax/libs/jquery-mousewheel/3.0.6/jquery.mousewheel.min.js, is invoked via document.write. The network request for this script MAY be blocked by the browser in this or a future page load due to poor network connectivity. If blocked in this page load, it will be confirmed in a subsequent console message. See https://www.chromestatus.com/feature/5718547946799104 for more details.
    (anonymous) @ jquery.mCustomScrollbar.min.js:8
    http://www.google-analytics.com/analytics.js:1 Failed to load resource: net::ERR_BLOCKED_BY_CLIENT
    scripts.min.js:42 shortcodes
    http://www.gstatic.com/recaptcha/api2/v1545073489967/recaptcha__en.js:499 Uncaught Error: Invalid site key or not loaded in api.js: 6LdgQYQUAAAAAFujcWaAkpYHpUrk8hoQAlPPmoUO
    at Object.zP [as execute] (www.gstatic.com/recaptcha/api2/v1545073489967/recaptcha__en.js:499)
    at execute (contact:354)
    at Yh (www.gstatic.com/recaptcha/api2/v1545073489967/recaptcha__en.js:502)
    at l (www.gstatic.com/recaptcha/api2/v1545073489967/recaptcha__en.js:498)
    http://www.gstatic.com/recaptcha/api2/v1545073489967/recaptcha__en.js:499 Uncaught Error: Invalid site key or not loaded in api.js: 6LdgQYQUAAAAAFujcWaAkpYHpUrk8hoQAlPPmoUO
    at Object.zP [as execute] (www.gstatic.com/recaptcha/api2/v1545073489967/recaptcha__en.js:499)
    at HTMLDocument.execute (contact:354)
    at Object.wpcf7.triggerEvent (scripts.js:367)
    at ajaxSuccess (scripts.js:298)
    at Object.<anonymous> (scripts.js:350)
    at i (jquery.js:2)
    at Object.fireWith [as resolveWith] (jquery.js:2)
    at y (jquery.js:4)
    at XMLHttpRequest.c (jquery.js:4)

    linux4me2

    (@linux4me2)

    @designernotacoder: Here’s the problem:

    
    http://www.gstatic.com/recaptcha/api2/v1545073489967/recaptcha__en.js:499 Uncaught Error: Invalid site key or not loaded in api.js: 
    

    You’re still loading reCAPTCHA v2, and probably not the v3 javascript. I see you’re using Cloudflare. You should probably next try clearing the cache on Cloudflare, any caching plugins you’ve got installed in WordPress, and finally your browser cache.

    You’ll know the badge when you see it; it looks like the little blue-and-white Google recycling thing to the right of the old “I’m not a robot” checkbox in v2, and it will appear on every page of your site.

    It looks like Google Analytics is also being blocked:

    
    http://www.google-analytics.com/analytics.js:1 Failed to load resource: net::ERR_BLOCKED_BY_CLIENT
    

    If that doesn’t get you going, the other thing to check is any add or script blocker you’ve got running as an extension in your browser, though I doubt that’s the issue if you tried the site in other browsers…

    designernotacoder

    (@designernotacoder)

    I think those were old errors as I am no longer using cloudfare

    Here is the log after clearing it:

    recaptcha__en.js:499 Uncaught Error: Invalid site key or not loaded in api.js: 6LdgQYQUAAAAAFujcWaAkpYHpUrk8hoQAlPPmoUO
    at Object.zP [as execute] (recaptcha__en.js:499)
    at HTMLDocument.execute (contact:354)
    at Object.wpcf7.triggerEvent (scripts.js?ver=5.1.1:367)
    at ajaxSuccess (scripts.js?ver=5.1.1:298)
    at Object.<anonymous> (scripts.js?ver=5.1.1:350)
    at i (jquery.js?ver=1.12.4:2)
    at Object.fireWith [as resolveWith] (jquery.js?ver=1.12.4:2)
    at y (jquery.js?ver=1.12.4:4)
    at XMLHttpRequest.c (jquery.js?ver=1.12.4:4)

    rmorek

    (@rmorek)

    I have exactly the same problem. No message on any page I have can be sent. The message states that it can not or can not because spam. I have changed the configurations of reCaptcha in google and made the integration with correct kesy. I have cleared the cache of my browser. No improvement.

    rmorek

    (@rmorek)

    It is my console:

    JQMIGRATE: Migrate is installed, version 1.4.1
    ?v=2.0:6 WebSocket connection to ‘wss://public-api.wordpress.com/pinghub/wpcom/me/newest-note-data’ failed: Error during WebSocket handshake: Unexpected response code: 403
    v @ ?v=2.0:6
    fmLCTmLuYvv.js:55 ErrorUtils caught an error: “<![EX[[“Tried to listen to element of type %s from %s: %s”,”click”,”Error”,”C…”. Subsequent errors won’t be logged; see https://fburl.com/debugjs.
    reportError @ fmLCTmLuYvv.js:55
    ytprefs.min.js?ver=13.0:2 Setting up YT API events: _ytid_95983
    ytprefs.min.js?ver=13.0:2 Setting up YT API events: _ytid_36361
    ytprefs.min.js?ver=13.0:2 Setting up YT API events: _ytid_55098
    ytprefs.min.js?ver=13.0:2 Setting up YT API events: _ytid_40592
    ytprefs.min.js?ver=13.0:2 Setting up YT API events: _ytid_53726
    ytprefs.min.js?ver=13.0:2 YT API ready 2
    2?v=2.0:6 WebSocket connection to ‘wss://public-api.wordpress.com/pinghub/wpcom/me/newest-note-data’ failed: Error during WebSocket handshake: Unexpected response code: 403

    fatkinson

    (@fatkinson)

    Well, I solved my issue.
    I replaced Contact Form 7 with WPForms.
    Adding Captcha into that is easy.

    fatkinson

    (@fatkinson)

    d

    Please back reCAPTCHA V2 – a lot of spam goes through the form!!!

    Hello,

    I am facing same issue with reCAPTCHA (v3). I have clear cache

    Here is my console:
    recaptcha__en.js:499 Uncaught Error: Invalid site key or not loaded in api.js:
    at Object.zP [as execute] (recaptcha__en.js:499)

    Also I check with reCAPTCHA (v2), facing same issue.

    What could be the problem? I my other site V3 working fine

    I found a solution to the problem where the console reported this error:

    Uncaught Error: Invalid site key or not loaded in api.js

    (and sending a message produced “There was an error trying to send your message. Please try again later” surrounded by a orange border)

    The solution was posted here and is to go to your recaptcha admin console over on google and make sure the domain name does *not* include “http://”. So, use “site.com” not “http://site.com”.

Viewing 15 replies - 1 through 15 (of 17 total)
  • You must be logged in to reply to this topic.