Support » Plugin: reCaptcha by BestWebSoft » reCaptcha not required to be completed on Register page

  • Resolved ciaranhan

    (@ciaranhan)


    Hi,

    The plugin works for me on the login page, but on the register page it is possible to login without completing the reCaptcha. I’m getting a lot of spam as a result. Could someone take a look please?

    Cheers.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author bestwebsoft

    (@bestwebsoft)

    Hi,

    Please complete the following steps in order to detect the problem and find its solution:

    1) Activate a default WordPress theme for a while (Twenty Nineteen or Twenty Twenty) and check if the problem remains.
    2) Deactivate all of your plugins except reCaptcha and also check if the problem is still present. If it is not, activate the plugins one-by-one, meanwhile checking, after which plugin activation the problem appears again.
    3) Contact us back with information about the results.

    I tried this and it’s still an issue even after I have deactivated all unnecessary plugins.

    When I added the shortcode [bws_google_captcha] then it works okay, but since it is not required, the users can bypass both the login/registration without touching the recaptcha at all.

    Then I created a custom form following what was on this link: https://support.bestwebsoft.com/hc/en-us/articles/202352499

    I kept getting an error: “You have entered an incorrect reCAPTCHA value.” even though I know for a fact that I have entered the correct value. I’ve checked the little details making sure my form names, IDs, filters were added correctly.

    I tried calling this function directly: gglcptch_check_custom()
    from google-captcha.php and it’s also returning false.

    Please advise.

    Plugin Author bestwebsoft

    (@bestwebsoft)

    Hi,

    Please verify that the keys are correct here – https://www.google.com/recaptcha/admin#list. If keys are correct, but the problem still remains, please try to generate new keys and enter them on the plugin settings page.

    After this try to follow the next instructions in order to test reCaptcha’s keys:
    1) Go to reCaptcha Settings page;
    2) Click “Test reCaptcha”;
    3) Test your reCaptcha;
    4) Then сlick “Test Verification”;

    Let us know about the result.

    Also, it’s necessary to check reCAPTCHA version because if you switched between Version 2 and Version 3, you should regenerate new keys.

    Hi,

    I have switched to Version 2 and regenerated new keys. Actually, I deleted the old
    API settings and created a new one thus regenerating a new key for this.

    I have tried the following per suggested and I am still encountering the same issue.

    EVEN though Google Verified the inputs are correct and showed a “green checkmarked”
    The variable $check_result is set to “You have entered an incorrect reCAPTCHA value.”

    on this line of code:
    $check_result = apply_filters(‘gglcptch_verify_recaptcha’, true, ‘string’, ‘my_custom_form’);

    while validating user input.

    Plugin Author bestwebsoft

    (@bestwebsoft)

    If you need customization for your form, submit a private ticker here: https://support.bestwebsoft.com/hc/en-us/requests/new

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘reCaptcha not required to be completed on Register page’ is closed to new replies.