Support » Plugin: Fast Secure Contact Form » reCaptcha just not showing

  • Hi there,

    I don’t know if you can help, but I am racking my brains trying to figure out why the reCaptcha won’t show up with my theme. Here is a sample:

    http://tqconstruction.staging.wpengine.com/request-a-construction-quote/

    I know it’s the theme because switching to Twenty Seventeen at least shows an invalid domain error and the reCaptcha box…which is totally fine because this is a staging site. But the theme we have, a Genesis child theme, won’t show anything at all – not even an error or a box. If it could just show an error, something at least, I feel we could start troubleshooting this. But it won’t.

    I’ve read this page: http://www.fastsecurecontactform.com/problem-captcha-image and this page http://www.fastsecurecontactform.com/recaptcha and I still can’t figure it out.

    I can confirm:
    No other reCaptcha
    Did not hide captcha from registered users or anyone
    Checked other scripts on the page, nothing seems to interfere, at least not obviously
    We have Jet pack carousel without Jetpack plugin, but even with this disabled, problem persists.
    No comments enabled on our site
    Using WP Engine hosting. But…doesn’t seem to be a problem when we switch to TwentySeventeen
    Updated to latest version of plugin and WP
    Tried disabling plugins but also didn’t work

    Any possible ideas? I can’t even figure out where to begin…

Viewing 3 replies - 1 through 3 (of 3 total)
  • The javascript does not load in the footer.

    Your theme may be missing the wp_footer() tag.
    Every theme needs a the wp_head() and wp_footer() tags or plugins may not function as designed. These tags are frequently used by plugins to add javascript, stylesheets, and meta tags.

    If it is missing, add
    <?php wp_footer(); ?>
    right before the last line in the footer.php file in your theme directory.
    To easily confirm if the theme you are using is the cause, activate one of the WordPress default themes and see if the problem goes away.

    Thread Starter joycegrace

    (@joycegrace)

    Hi Mike, thanks. yes I did red your page. We had this on our footer.php file:

    <?php wp_footer(); ?>
    </body>
    </html>

    And I tried changing it o

    </body>
    <?php wp_footer(); ?>
    </html>

    Which is what it’s at right now (latter version). It still doesn’t show.

    any ideas?

    Same problem here. Had multiple Recaptcha instances from older contact forms, but narrowed it down. Still a no-show.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘reCaptcha just not showing’ is closed to new replies.