• Resolved brandon321

    (@brandon321)


    Hey. I’ve been getting this error quite often on different sites.

    Google recaptcha verification failed, please try again later.

    I’ve been trying to find answers to it and tried fixing it but nothing seems to work. I’ve tested it on different themes and WordPress’s default theme and problems exists. I’ve made reCAPTCHA’s again multiple times and tried different versions of reCAPTCHAS’s but everytime it’s the same problem. The weird thing is that it does work on some of my sites but not in all. Mostly the difference between sites is the host, but mostly sites use the same themes and same plugins. I’ve had to use the form without reCAPTCHA on these sites and that’s not very good solution. The error has started to occur in the past 4 months I think. Any idea?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Support Ethan Choi

    (@ethanchoi)

    Hi @brandon321,

    When you get the chance, could you share more details regarding the error, such as error messages, screenshots, and the URL(s) to your web page where the form is embedded?

    Thanks!

    Hey. The form can be found for example in here:

    https://ise.fi/kartoitus/

    It just says “Form has not been submitted, please see the errors below.” and the error below is “Google reCAPTCHA verification failed, please try again later.”. Clicking the captcha box works but after clicking the send button the page just loads and gives the error.

    I’m gonna have to remove the captcha since answering seems to take time. The form needs to be working right now even without captcha. But here’s a screenshot of the errors:

    https://imgur.com/6JW7bME

    Plugin Support Ethan Choi

    (@ethanchoi)

    Hi @brandon321,

    Thanks for the details!

    If you’re encountering this error, it could be that reCAPTCHA is getting loaded twice on the page — once by WPForms, and once by either your theme settings or another plugin, and this causes the error in the form.

    The possible next steps could be:

    1. You can try to track down what’s generating the other reCAPTCHA code and, if possible, turn it off.

    2. You can enable No-Conflict Mode in WPForm’s reCAPTCHA settings (under WPForms > Settings > reCAPTCHA tab

    I hope this helps 🙂

    Hey. I have only 4 plugins installed on the site:

    Advanced Custom Fields PRO
    Classic Editor
    Limit Login Attempts Reloaded
    WPForms Lite

    So really basic plugins which should have no impact on it. To make sure I disabled them but nothing changed. I also tried the default 2020 WordPress theme and the problem exists. I also tried making the keys with a my other Google account just for the heck of it but no cigar. I simply don’t understand this…

    Plugin Support Ethan Choi

    (@ethanchoi)

    Hi @brandon321,

    Thanks for the updates!

    Did you manage to try the No-Conflict Mode in WPForm’s reCAPTCHA settings page (WPForms > Settings > reCAPTCHA)?

    If that does not resolve the issue, could you try setting up a test page with a form that has reCAPTCHA enabled so we can take a closer look?

    Thanks!

    Plugin Support Ethan Choi

    (@ethanchoi)

    Hi @brandon321,

    We haven’t heard back from you in about a week, so I’m going to go ahead and close this thread for now. But if you’d like us to assist further, please feel welcome to continue the conversation.

    Thanks!

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.