Support » Plugin: Simple Q&A » reCAPTCHA error

  • Resolved Amr Ali

    (@amr3li)


    Hello

    After Simple Q&A 1.4 update, suddenly the reCaptcha is always returning verification error after clicking “submit”, even though the reCaptcha itself shows that verification was successful before clicking “submit”

    Thank you

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Evgeniy Kutsenko

    (@jon4god)

    I tried on three different projects with this plugin. Everything is working. Try reinstalling the plugin and check the settings. If the problem persists please write.

    Thread Starter Amr Ali

    (@amr3li)

    Alright, Plugin was deactivated and deleted,
    re installed again and the CAPTCHA still returning error,
    WP is installed in a subdirectory and here is what I am getting when debugging,

    The notice is produced when I try to save Simple-qa settings:

    [18-Apr-2016 11:31:47 UTC] PHP Notice:  options.php was called with an argument that is <strong>deprecated</strong> since version 2.7! The <code>qa_setting_pagination</code> setting is unregistered. Unregistered settings are deprecated. See https://codex.wordpress.org/Settings_API in /home/elamal/public_html/devx/wp-includes/functions.php on line 3846
    [18-Apr-2016 11:31:47 UTC] PHP Notice:  options.php was called with an argument that is <strong>deprecated</strong> since version 2.7! The <code>qa_setting_default_answer</code> setting is unregistered. Unregistered settings are deprecated. See https://codex.wordpress.org/Settings_API in /home/elamal/public_html/devx/wp-includes/functions.php on line 3846
    [18-Apr-2016 11:31:47 UTC] PHP Notice:  options.php was called with an argument that is <strong>deprecated</strong> since version 2.7! The <code>qa_setting_background_close</code> setting is unregistered. Unregistered settings are deprecated. See https://codex.wordpress.org/Settings_API in /home/elamal/public_html/devx/wp-includes/functions.php on line 3846
    [18-Apr-2016 11:31:47 UTC] PHP Notice:  options.php was called with an argument that is <strong>deprecated</strong> since version 2.7! The <code>qa_setting_background_open</code> setting is unregistered. Unregistered settings are deprecated. See https://codex.wordpress.org/Settings_API in /home/elamal/public_html/devx/wp-includes/functions.php on line 3846
    [18-Apr-2016 11:31:47 UTC] PHP Notice:  options.php was called with an argument that is <strong>deprecated</strong> since version 2.7! The <code>qa_setting_number_qa</code> setting is unregistered. Unregistered settings are deprecated. See https://codex.wordpress.org/Settings_API in /home/elamal/public_html/devx/wp-includes/functions.php on line 3846
    [18-Apr-2016 11:31:47 UTC] PHP Notice:  options.php was called with an argument that is <strong>deprecated</strong> since version 2.7! The <code>qa_setting_captcha_publickey</code> setting is unregistered. Unregistered settings are deprecated. See https://codex.wordpress.org/Settings_API in /home/elamal/public_html/devx/wp-includes/functions.php on line 3846
    [18-Apr-2016 11:31:47 UTC] PHP Notice:  options.php was called with an argument that is <strong>deprecated</strong> since version 2.7! The <code>qa_setting_captcha_privatekey</code> setting is unregistered. Unregistered settings are deprecated. See https://codex.wordpress.org/Settings_API in /home/elamal/public_html/devx/wp-includes/functions.php on line 3846
    [18-Apr-2016 11:31:47 UTC] PHP Notice:  options.php was called with an argument that is <strong>deprecated</strong> since version 2.7! The <code>qa_setting_user_response</code> setting is unregistered. Unregistered settings are deprecated. See https://codex.wordpress.org/Settings_API in /home/elamal/public_html/devx/wp-includes/functions.php on line 3846
    [18-Apr-2016 11:31:47 UTC] PHP Notice:  options.php was called with an argument that is <strong>deprecated</strong> since version 2.7! The <code>qa_setting_captcha</code> setting is unregistered. Unregistered settings are deprecated. See https://codex.wordpress.org/Settings_API in /home/elamal/public_html/devx/wp-includes/functions.php on line 3846
    [18-Apr-2016 11:31:47 UTC] PHP Notice:  options.php was called with an argument that is <strong>deprecated</strong> since version 2.7! The <code>qa_setting_default_email</code> setting is unregistered. Unregistered settings are deprecated. See https://codex.wordpress.org/Settings_API in /home/elamal/public_html/devx/wp-includes/functions.php on line 3846
    [18-Apr-2016 11:31:47 UTC] PHP Notice:  options.php was called with an argument that is <strong>deprecated</strong> since version 2.7! The <code>qa_setting_email</code> setting is unregistered. Unregistered settings are deprecated. See https://codex.wordpress.org/Settings_API in /home/elamal/public_html/devx/wp-includes/functions.php on line 3846

    Also I have suggested all the Arabic Translation Strings for the plugin but not accepted yet “no editors”
    And I have created an RTL css for Simple-qa and it fits well in my RTL website. but not sure how to enqueue it!

    Thank you

    Plugin Author Evgeniy Kutsenko

    (@jon4god)

    Wow!
    I tried to test the site in Arabic, and again I have everything working. Can you give a link to your site? I watch it.
    Error when debugging is known. On the work is not affected, but I think rewrite plugin settings. I’m waiting for free time.
    I applied for the inclusion of you as an editor of the project, but will be faster if you contact with the general editors of the Arabic language.
    RTL css write here or I can take them to your site. Turn them into a plugin.

    Thank you for participating.

    Thread Starter Amr Ali

    (@amr3li)

    Alright, Here is a link to the site:

    I have edited qa-plugin.css to the following css, I made it more flatty and full width boxes to fit in most WordPress Page Builders or the Default Editor and its totally RTL.

    [Large code excerpt removed by moderator per forum rules. Please use Pastebin for all large code excerpts. It works better anyway.]

    Also I highly suggest that this qatag bottom-margin in qa-plugin.php <li class="<?php echo $qa_tags; ?>" style="border-bottom:1px solid #fff;">
    to be handled in the css if possible and not the php.

    Sidenote: Your plugin Simple Q&A is promising, It’s meant to be simple and it is simple. all other Question & Answers plugin are complicated and getting more and more like stack overflow and yahoo answers style which many users do not really need.

    Please check the site and reply with what you see better,
    Thank you for the good work, I am looking forward to help.

    Thread Starter Amr Ali

    (@amr3li)

    Hey again, the RTL css: http://pastebin.com/MgMbvsUa

    Plugin Author Evgeniy Kutsenko

    (@jon4god)

    Updated plugin. Write if the error remains with captcha.
    Thank you very much for your participation!

    Thread Starter Amr Ali

    (@amr3li)

    Hello there,

    Captcha still returning ERROR, even though in google reCaptcha settings its set to the minimum security level and Domain Name Validation is marked.

    Pagination stopped working, Q&A page slug gets stipped off when clicking on pagination arrows or numbers.

    Font color for Q&A is not applied because its overridden in “qa-plugin-rtl.css”

    I also contact general Arabic Editor https://profiles.wordpress.org/alex-ye to validate your “Arabic” PTE request, hopefully its sorted soon.

    Thank you for the follow up!

    Plugin Author Evgeniy Kutsenko

    (@jon4god)

    Thanks for pointing errors. Updated the plugin.
    With captcha on my projects no errors. Don’t even know how to help.

    Thread Starter Amr Ali

    (@amr3li)

    It seems that the problem is only happening in my hosting end.
    Thank you for all the help and support you provided.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘reCAPTCHA error’ is closed to new replies.