Support » Plugin: Jobs for WordPress » Recaptcha check not working

  • szwebcom

    (@szwebcom)


    I tried using recaptcha v2 & v3 – but every time I send the form, the error message “Ups… reCaptcha identified you as a bot. If you are not, please reload and try again.” comes up.
    I already deactivated “Complianz” and “WPRocket” Plugins, but still the same error. Looks like recaptcha answer is invalid json.

    Any ideas how to fix this?

Viewing 4 replies - 16 through 19 (of 19 total)
  • Plugin Author BlueGlass Interactive

    (@blueglassinteractive)

    @szwebcom
    Sorry, had to clarify, last update fixes upload issue.

    Can you give us admin access to your site so we could test?
    For user admin@blueglass.ee

    Also, recaptcha verification uses external connection/request to google servers, could be this somehow blocked on your server?

    Br

    @blueglassinteractive

    Sorry, I can’t give you access to our productive website. We’re also using re-captcha v3 in our contact form, which is working fine. So I don’t think it has something to do with connecting the google servers.
    I switched to re-captcha v2 in the Plugin – this is working. So it looks like there might be a bug with v3?

    I’m also experiencing issues with file attachments in the current version. When clicking on the attachment in an application it is not found: 404 — File not found.
    (what is the “secure location” on the server where the data gets stored?)

    Plugin Author BlueGlass Interactive

    (@blueglassinteractive)

    @szwebcom

    “Secure location” is where you cant access files directly from internet with a simple permalink, like when files stored in WP Media. “Secure location” located one level up from your sites root location. As we prompted with a large banner/notice, after we integrated this feature, it can happen that its not working on some servers due to it’s limitations or configuration. A simplye switch of file location in settings, returns the legacy way of storing file in WP Media, but it’s insecure to sensitive data that might be included in CV’s…

    Workaround here is to switch file location to WP Media in settings.

    Additionally, You can also activate “Don’t store user data” option. It will only process the data and delete it from server, as soon email is sent out to you. But be sure emails is sent out and files are attached 😉

    PS: We will do some more tests on V3 recaptcha as soon we have time…

    Br

    @blueglassinteractive

    I switched to “Unsafe location” and activated “Don’t store user data” – thanks.

Viewing 4 replies - 16 through 19 (of 19 total)
  • You must be logged in to reply to this topic.