Support » Plugin: Jobs for WordPress » Recaptcha check not working

  • szwebcom

    (@szwebcom)


    I tried using recaptcha v2 & v3 – but every time I send the form, the error message “Ups… reCaptcha identified you as a bot. If you are not, please reload and try again.” comes up.
    I already deactivated “Complianz” and “WPRocket” Plugins, but still the same error. Looks like recaptcha answer is invalid json.

    Any ideas how to fix this?

Viewing 15 replies - 1 through 15 (of 19 total)
  • OrbicularMedia

    (@rallycrosslife)

    I am experiencing the same problem. I have tired v2 and v3. For v2, the checkbox shows a check but the plugin gives an error. My recaptcha account does not show any failed attempts so the the form submissions are verified by Google.

    I did some troubleshooting myself. According to Google, the POST parameter is supposed to be “g-recaptcha-response” in the form. The plugin has a misspelling as “recaptca_response”. I have changed the 3 misspelled instances in my installation. Unfortunately, this did not fix the problem and the form gives the same error message.

    I have installed the app on a fresh install of WordPress and get the same error.

    Hello,

    Same here, the error doesn’t pop up all the time but too often to use reCaptcha validation. Not sure if problem coming from reCaptcha or from plugin but I deactivated it for now to be sure people can apply.

    Will be awesome to have some feedback on this. πŸ™‚

    How can you completely deactivate reCaptcha? I can only set v2 or v3 in the settings.

    You can completely deactivate recaptcha by removing your keys in the setting. Leaving those fields blank removes recaptcha.

    I have contacted the company through their website with no response.

    Ah, thanks @rallycrosslife!

    I got a response from BlueGlass Tallinn, the software company. They are aware of the problem and are looking into it.

    Hopefully they will be able to fix and issue an update soon.

    Plugin Author BlueGlass Interactive

    (@blueglassinteractive)

    Hi @szwebcom
    Hi @rallycrosslife
    Hi @carnets2routards

    Our test don’t show such behavior as you describe. We tested on multiple setups, V2 & V3 with different setting in re-captcha console.
    Cant replicate the issue.

    Could some of you pass URL where this happens?

    Additionally, we still did some changes in mechanism of how re-captcha validation works, please update and try the new version.

    Also what I can think of, could happen that validation dont work if your website has JS errors in browser console, some JS error can bloc other JS to work properly… please also check this on your websites too.

    Br,

    I have updated and still experience the same problem.

    I have setup a development site where only your plugin is installed. I get the same error. I am using recaptcha v2.

    https://dev.orbicular.media/jobs/

    The test job application can be filled out for testing.

    Plugin Author BlueGlass Interactive

    (@blueglassinteractive)

    @rallycrosslife

    Can you provide admin access to this test site?

    to email admin@blueglass.ee

    You should have an email with access credentials. The latest update does not fix the issue.

    Sorry for the late reply, I am not getting notified of replies to this site.

    Plugin Author BlueGlass Interactive

    (@blueglassinteractive)

    Hi @rallycrosslife
    Hi @szwebcom
    Hi @carnets2routards

    We realeased the update that fixes the issue. Please update the plugin on your site and check.

    @rallycrosslife thank you for proving the testing environment where issue happens, this helped! πŸ™‚

    Best regards

    Recaptcha works with the current update!

    Now, when I try to attach a PDF to the submit form, the form fails to complete and the spinning dots do not go away. There is no error message.

    The test environment is still active and experiencing the issue. I have tested both secure location and media with the same issue.

    Just to add. the issiue of the failing Recaptcha on the latest release is also happening on my site so I have switched off Recaptcha for the meantime. What does happen even when there is an error however is that the Application gets submitted but without the Attachments
    Cheers
    Wynter

    Plugin Author BlueGlass Interactive

    (@blueglassinteractive)

    @rallycrosslife
    @wynterblathwayt

    Thank you for quickly pointing this out! Should be fixed now.

    Sorry for silly issue πŸ™‚

    @blueglassinteractive

    I’ve upgraded 2.4.7 and re-enabled re-captcha v3. Nevertheless: the same error is still occuring: “Ups… reCaptcha identified you as a bot. If you are not, please reload and try again.”

    I tried Chrome (+ Incognito) and Firefox (+ Incognito) – all the same.

Viewing 15 replies - 1 through 15 (of 19 total)
  • You must be logged in to reply to this topic.