Support » Plugin: Contact Form by WPForms - Drag & Drop Form Builder for WordPress » recaptcha broke with last update

  • Resolved mbeerli

    (@mbeerli)


    I have my contact form a long time, I think with the latest upgrade the recaptcha broke.
    In the contact form when I edit and go to settings, I had checked “Enable Google v3 reCAPTCHA” if enabled, it displays in the edit mode correctly. But using the website, I can not send an email.
    Error: Google reCAPTCHA verification failed, please try again later.

    When filling out the form on the website the recaptcha is not displayed.
    But it is displayed when editing the contact form.

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Support Ethan Choi

    (@ethanchoi)

    Hi @mbeerli,

    It looks like there might be a conflict between the forms and the site theme or another plugin. To troubleshoot this, please try the steps described in our detailed guide on how to test for plugin/theme conflicts.

    Hope this helps!

    Hello Ethan,
    I do not have a testsite. That is way to much work to test.
    This worked until a little while ago.
    No other plugin was installed.
    I just activated the Twenty Nineteen theme and the Recaptcha was not shown, after enabling the checkbox in your settings.
    So not the theme.
    How else can we debug it?
    I have a plugin called “Google Captcha (reCAPTCHA) by BestWebSoft” but I disabled it, with no success. Still not showing recaptcha.

    I left your setting enabled so you can test, why it is not showing.
    Right now I get: Google reCAPTCHA verification failed, please try again later.

    • This reply was modified 5 months, 2 weeks ago by mbeerli.
    Plugin Support Ethan Choi

    (@ethanchoi)

    Hi @mbeerli,

    When you get the chance, could you try clearing any reCAPTCHA keys within the “Google Captcha (reCAPTCHA) by BestWebSoft” plugin and save its settings to see if that resolves the issue?

    Thanks!

    “Google Captcha (reCAPTCHA) by BestWebSoft” cleared both keys, saved and reloaded Contact Us page after clearing cache, still no reCaptcha on the page.

    I even tried to switch to V2 on the “Google Captcha (reCAPTCHA) by BestWebSoft”, since your plugin is using V3

    My question though: On the google website I generated 2 keys for the BestWebSoft pluging, on yours there are no keys. How does yours work?

    Like I said in the edit page of “Contact Form” it shows the recaptcha, but on the life “Contact Us” page it does not show, and that is why the error is generated.

    Plugin Support Ethan Choi

    (@ethanchoi)

    Hey @mbeerli,

    Thanks for the update. To add reCAPTCHA keys to WPForms, you can go to WPForms > Settings and click on the reCAPTCHA tab. For a step-by-step guide, please see our reCAPTCHA setup doc.

    Hope this helps!

    that was it. The keys changed for whatever reason.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.