WordPress.org

Forums

really weird. posts in a category not displaying (12 posts)

  1. cscott5288
    Member
    Posted 3 years ago #

    Not sure if this is related but I recently updated several of my plugins and upgraded WP from 3.2 to 3.2.1.

    I have a link in my menu that goes to all posts in an entire category, running through archive.php. For some inexplicable reason, the posts are no longer being displayed. I instead get:

    Not Found

    Sorry, but you are looking for something that isn't here.

    Here is the link: http://www.viewfromthebleachers.net/category/fishful-thinking/

    Any idea why the archive page is not showing up for this category? It shows up for other categories (example: http://www.viewfromthebleachers.net/category/fun-and-leisure-humor/)

    but not for the category titled "Fishful Thinking." I checked in the categories page and the category "Fishful Thinking" does indeed contain posts and has the slug 'fishful-thinking'. So the url is right ... but I can't view all posts even from hitting the "view" button on the Categories page.. Really weird. Any help highly appreciated.

  2. christogeretz
    Member
    Posted 3 years ago #

    Clicking on the Sept 2011 link in the footer gives an error
    http://www.viewfromthebleachers.net/2011/09/?cat=-139

    I checked in the categories page and the category "Fishful Thinking" does indeed contain posts

    Are you sure? I just went through six or seven months of archives and didn't see any with that category. Try creating a new post with that category??

  3. jetskiron
    Member
    Posted 3 years ago #

    I have the same exact thing happening on some of my pages as of a couple days ago. I did not do any updates. http://www.insuranceclaimhelp.org

  4. christogeretz
    Member
    Posted 3 years ago #

    Jetskiron - what categories?

  5. jetskiron
    Member
    Posted 3 years ago #

    Actually the posts are missing from the right side bar pages when I am logged into WordPress Admin Dashpanel and viewing the website using Firefox. If I view the website in IE8 at anytime, then all I get is

    "Sorry, but you are looking for something that isn't here."

    It happens in various, not all, top pages and side pages. Go to the site adn click around. I get the message

    Have you checked to see if your .htaccess file in the root is getting overwritten?

  6. cscott5288
    Member
    Posted 3 years ago #

  7. christogeretz
    Member
    Posted 3 years ago #

    Fair enough. Do you have any posts in two categories, one of which is Fishful Thinking?

    I'm wondering if there's a connection between this category not showing and the Sept 2011 archives page resulting in an error....hmm

  8. cscott5288
    Member
    Posted 3 years ago #

    Interestingly no, and not all of the fishshful thinking posts are in Sept. Thanks for the help btw :)

  9. christogeretz
    Member
    Posted 3 years ago #

    Why not try a test post - on an older post in a different category, assign FT category as well?

  10. cscott5288
    Member
    Posted 3 years ago #

    Tried. It still didn't appear in the FT category archive.

  11. christogeretz
    Member
    Posted 3 years ago #

    you've checked that the category name and the slug match?

    BTW - I keep getting errors like

    Parse error: syntax error, unexpected T_ENDIF in /home/content/13/4895013/html/wp-content/themes/bleachers/404.php on line 40

    Might want to fix that :)

  12. cscott5288
    Member
    Posted 3 years ago #

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.