WordPress.org

Support

Support » Plugins and Hacks » really-simple-captcha.php on line 126 & 144

really-simple-captcha.php on line 126 & 144

  • Hi,

    I’m using WP ver 3.3.2 and have contact form 7 ver 3.2 with really simple captcha ver 1.5.

    I was actually using the backWPup plugin 2.1.17 to do a backup of my website and received these unable to write the really simple captcha temp folder errors and my backup could not carry on. So I had to abort my backups, so I tried changing the permission and still it would not work.

    So to test it out I deactivate the really simple captcha to see if the issue will go away. It did not work too, so I reactivated the really simple captcha and now I have these errors on line 126 & 144

    Please see my website http://www.new-property-launches.com, you will notice these errors appearing at the contact form at bottom right hand corner.

    Basically I’m receiving these errors:

    Security Code *
    Warning: imagepng() [function.imagepng]: Unable to open ‘/home/newprope/public_html/wp-content/plugins/really-simple-captcha/tmp/56229498.png’ for writing: Permission denied in /home/newprope/public_html/wp-content/plugins/really-simple-captcha/really-simple-captcha.php on line 126

    Warning: fopen(/home/newprope/public_html/wp-content/plugins/really-simple-captcha/tmp/56229498.txt) [function.fopen]: failed to open stream: Permission denied in /home/newprope/public_html/wp-content/plugins/really-simple-captcha/really-simple-captcha.php on line 144

    Could you advise on how to resolve this issue?

    email : samgmutthan67@yahoo.com.sg

    Thanks
    Rdgs

    http://wordpress.org/extend/plugins/really-simple-captcha/

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Takayuki Miyoshi
    Participant

    @takayukister

    Contact Form 7 doesn’t use the really-simple-captcha/tmp directory to store CAPTCHA images unless you have defined it as WPCF7_CAPTCHA_TMP_DIR.

    CAPTCHA

    Check your settings.

    Also, you should update WordPress and plugins. They are outdated.

    Hi Takayuki Miyoshi,

    Thanks for your help, I have checked through based on your advice on the WPCF7_CAPTCHA_TMP_DIR.
    There is only a .htacess file there and I opened it to verify and this is specified there as stated below ;

    Order deny,allow
    Deny from all
    <Files ~ “^[0-9A-Za-z]+\.(jpeg|gif|png)$”>
    Allow from all
    </Files>

    Actually I tried to backup my files before performing an upgrade on plugins and wordpress itself and that’s when all this started to happen.

    Can I simply do an upgrade on wordpress and plugins now and try again with your really simple captcha version 1.6 ? Do you think this might help?

    Please advise thanks
    rdgs

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘really-simple-captcha.php on line 126 & 144’ is closed to new replies.