WordPress.org

Support

Support » How-To and Troubleshooting » Really old publish dates not possible

Really old publish dates not possible

  • I have a user who wants to use WP to make a chronology of his life, using Publish dates as timestamps. But apparently WP won’t let you enter dates before the beginning of the unix epoch. You cannot save a post with a publish date in 1961, for example!

    Is there any known workaround for this?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Moderator Mark Ratledge

    @songdogtech

    Forum Moderator

    I doubt very much any modern unix software can work without the constraints of unix and timestamps. It’s the way these things (called computers) manage to work correctly.

    You’ll need to hack the PHP time functions in core files to finagle years like that; maybe subtract 50 years from the current server time. But then maybe use a custom field to trigger “real” PHP time to account for newer posts.

    Looks like this is a bug that’s actually being worked on:
    http://core.trac.wordpress.org/ticket/10332

    But it’s not fixed in 2.8.4 🙁

    Moderator Mark Ratledge

    @songdogtech

    Forum Moderator

    Interesting. So maybe something like that can work. Wonder how far back it all will go? To the dinosaur days?

    Moderator Mark Ratledge

    @songdogtech

    Forum Moderator

    Another idea from a different thread suggested using a custom field with the back date that you want, and modify your template to show the custom field instead of the current date, and then sort on that custom field for a chronology. With that, you’re not bound by the system clock and can date posts anyway you want.

    I fell for the same problem (I have a blog, Briefe an Else, dealing with early 20th century letters), and I know for a fact that it worked about a year ago – I was fascinated then to see that it worked. Now I am saddened and hit by the a. m. #10332. Hope that it will be resolved.

    @Songdotech, the post you were last referring to would be this, I presume.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Really old publish dates not possible’ is closed to new replies.
Skip to toolbar