WordPress.org

Support

Support » Themes and Templates » P2 Theme – Real Time Updating Not Working

P2 Theme – Real Time Updating Not Working

  • equalmark

    @equalmark

    All of a sudden, after working fine, when I write a new post using the form at the top of the homepage, the real time update does happen (the ajax loading of the new post written) and I get a message pop up in the middle of the screen saying:

    “your update has been posted”

    I have to refresh the page to see the post. Any ideas why? I have added nothing in terms of changes to the theme before it stopped working and haven’t changed any plugins.

    Any help would be appreciated. Thanks,

Viewing 15 replies - 1 through 15 (of 45 total)
  • designfollow

    @designfollow

    Have you tried changing the browser, the problem may be it

    equalmark

    @equalmark

    Just tried it in a few browsers and I am getting the same. Also noticed that when inputting the tags on the home page for writing a post, it is not giving tag suggestions as it used to either. Strange….

    Anyone any ideas. Seems strange why it should have stopped working.

    equalmark

    @equalmark

    I am a little confused at this error. If I show threaded comments and then comment (reply) to one of the posts on the homepage the ajax works and it updates ‘real time’. Anyone have a clue what could have changed?

    I am still suffering this problem even after updating to the latest 1.1.3 of this theme. Anyone any ideas?

    I have used the theme on two different domains. Works fine on one but not the other. Not sure what to check really.

    Any help you be appreciated.

    I thought that was the behavior it was supposed to do when updating not from the main page but from your /author/ page. Does it update fine from the blog homepage?

    It is on the homepage that I am having the problems.

    I have the same problem with wp 2.9 + p2 1.1.3
    The post is not refreshed dynamically like it used to back in p2 1.0.5

    My installation was completely new.

    Anyone else experience the same issue?

    What version of PHP is running for you guys?

    <<I have used the theme on two different domains. Works fine on one but not the other. Not sure what to check really.>>

    Is it on different hosting / servers?

    was working fine with p2 1.1.3 UNTIL i upgraded to WP 2.9 FINAL.

    backed up everything, deleted the entire WP installation, and reinstalled WP 2.9 and P2 1.1.3 only. No joy, still doesn’t auto update like it did.

    thoughts?

    your PHP version question jogged something loose in the brainpan…

    it seems like this domain got reset to php4 (not sure how that happened). when i reset it back to php5, it began working again. thanks!

    @everyone – see if using php5 fixes things for you.

    You guys rock! Yep, it’s the PHP4 issue. I thought I read somewhere that says php4 is now supported. Maybe I’m just getting old … 😛

    Thanks all!

    @nobble the sites where running on two different servers. One was Windows IIS7 and the other a linux server

    @gonegreengeek both of the servers are running PHP 5 and still the problem persists.

    Anyone any other ideas? It was working and then stopped 🙁

    Another vote for running the latest WP (2.9.1 beta 1), P2 (1.1.3), PHP5, etc., and the ajaxian updating is not working for posts, only comments.

    Any ideas of where to start looking?

    In terms of troubleshooting it’s probably helpful to also mention whether your p2 install is with or without plugins installed. In case of plugins, have you tried deactivating them and does the problem persist? Have multiple users reported the same problem on your specific site?

    Yes, with all plug-ins deactivated (this is a brand new installation), and, yes, it happens to all of us (only 3 users for now).

    Like the OP, it did work for a while.

Viewing 15 replies - 1 through 15 (of 45 total)
  • The topic ‘P2 Theme – Real Time Updating Not Working’ is closed to new replies.
Skip to toolbar