• Resolved auxschwarz

    (@auxschwarz)


    Hello there

    I’ve set a cluster which have 2webservers (sync by unison) and 2 dbservers (mariadb galera) and haproxy 7 load balancer instance.

    I’m trying to set Redis-Sentinel up but i’m getting an issue

    Webserver1 is master for redis sentinel and webserver2 is slave for redis sentinel.

    I’ve finished to set up redis sentinel and then I’m testing my website but i’m getting an issue

    Error establishing a Redis connection
    READONLY You can't write against a read only replica. WordPress is unable to establish a connection to Redis. This means that the connection information in your wp-config.php file are incorrect, or that the Redis server is not reachable. Is the correct Redis host and port set?
    Is the Redis server running?
    If you need help, please read the installation instructions. To disable Redis, delete the object-cache.php file in the /wp-content/ directory. This message was triggered by woocommerce. Call stack: wp_die()
    wp-content/object-cache.php:2947
    WP_Object_Cache->show_error_and_die()
    wp-content/object-cache.php:2879
    WP_Object_Cache->handle_exception()
    wp-content/object-cache.php:2164
    WP_Object_Cache->set()
    wp-content/object-cache.php:294
    wp_cache_set()
    wp-includes/option.php:990
    set_transient('shipping-transient-version')
    wp-content/plugins/woocommerce/includes/class-wc-cache-helper.php:225
    WC_Cache_Helper::get_transient_version()
    wp-content/plugins/b2bking/public/class-b2bking-public.php:780
    B2bking_Public->{closure}()
    wp-includes/class-wp-hook.php:310
    do_action('plugins_loaded')
    wp-settings.php:495

    When I move pages from pages, sometimes it happens. after the error page, I refresh the page, and it works well again

    Status: Connected
    Client: PhpRedis (v5.3.7)
    Drop-in: Valid
    Disabled: No
    Ping: 1
    Errors: []
    PhpRedis: 5.3.7
    Relay: Not loaded
    Predis: 2.1.2
    Credis: Not loaded
    PHP Version: 8.1.22
    Plugin Version: 2.4.4
    Redis Version: 6.0.16
    Multisite: No
    Metrics: Enabled
    Metrics recorded: 15
    Filesystem: Working
    Global Prefix: "wp_"
    Blog Prefix: "wp_"
    WP_REDIS_CLIENT: "phpredis"
    WP_REDIS_SERVERS: [
    "tcp://10.34.112.4:26379",
    "tcp://10.34.112.5:26379"
    ]
    WP_REDIS_SENTINEL: "mymaster"
    WP_REDIS_PREFIX: "bTz$:r0K9Ok}ixW;2f=}@eDPigxQ-{M56:fYSEKaY3kH5+D=$~QBh$#P CEh}E6)"
    WP_CACHE_KEY_SALT: "bTz$:r0K9Ok}ixW;2f=}@eDPigxQ-{M56:fYSEKaY3kH5+D=$~QBh$#P CEh}E6)"
    WP_REDIS_PLUGIN_PATH: "/var/www/html/wp-content/plugins/redis-cache"
    WP_REDIS_PASSWORD: ••••••••
    Global Groups: [
    "blog-details",
    "blog-id-cache",
    "blog-lookup",
    "global-posts",
    "networks",
    "rss",
    "sites",
    "site-details",
    "site-lookup",
    "site-options",
    "site-transient",
    "users",
    "useremail",
    "userlogins",
    "usermeta",
    "user_meta",
    "userslugs",
    "redis-cache",
    "blog_meta",
    "network-queries",
    "site-queries",
    "user-queries"
    ]
    Ignored Groups: [
    "counts",
    "plugins",
    "themes",
    "theme_json"
    ]
    Unflushable Groups: []
    Groups Types: {
    "blog-details": "global",
    "blog-id-cache": "global",
    "blog-lookup": "global",
    "global-posts": "global",
    "networks": "global",
    "rss": "global",
    "sites": "global",
    "site-details": "global",
    "site-lookup": "global",
    "site-options": "global",
    "site-transient": "global",
    "users": "global",
    "useremail": "global",
    "userlogins": "global",
    "usermeta": "global",
    "user_meta": "global",
    "userslugs": "global",
    "redis-cache": "global",
    "counts": "ignored",
    "plugins": "ignored",
    "themes": "ignored",
    "blog_meta": "global",
    "network-queries": "global",
    "site-queries": "global",
    "user-queries": "global",
    "theme_json": "ignored"
    }
    Drop-ins: [
    "Query Monitor Database Class (Drop-in) v3.12.3 by John Blackbourn",
    "Redis Object Cache Drop-In v2.4.4 by Till Krüss"
    ]

    Please help me

    • This topic was modified 10 months, 3 weeks ago by auxschwarz.
Viewing 1 replies (of 1 total)
  • Plugin Author Till Krüss

    (@tillkruess)

    Your WP_REDIS_SERVERS looks correct, so it must be your Redis Sentinel setup.

    Redis Sentinel is an advanced topic, I cannot help you with your infrastructure.

    You can either read the docs, or use a simpler setup.

Viewing 1 replies (of 1 total)
  • The topic ‘READONLY You can’t write against a read only replica. (in Sentinel)’ is closed to new replies.