Support » Plugin: Reading Time WP » Reading Time displays < 1

  • Resolved leightonrodney

    (@leightonrodney)


    Hi,

    Before your most recent update my shortcode in my single page custom post type template was working.

    See below:
    <?php echo do_shortcode(‘[rt_reading_time postfix=”minute”]’); ?>

    Now after the update it displays < 1 for all posts.

    Any ideas as to why? Even with stock wordpress theme it does this with no other plugins installed.

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • @leightonrodney are you using a page builder for your single page custom post type? In my case if I use a page builder then the plugin is not able to parse the content so it always gives “< 1 minute”. It only works if I use the default WordPress editor.

    Yes I am using a page builder. It was working with the page builder before the update. In my case I have to use the page builder. I cannot switch to the default WordPress editor.

    Plugin Author Jason Yingling

    (@yingling017)

    What page builder are you using?

    Reading Time WP has always stripped shortcodes which is typically how the content is added through page builders.

    I’m not sure how it would have worked previously if shortcodes are the culprit. The only update to the calculation function in the latest update was to add a filter for adding to the word count on your own. But if without that filter being used by your theme nothing would change.

    Is it possible the plugin had been edited before to remove the strip_shortcodes line as in this support request? https://wordpress.org/support/topic/not-counting-posts-made-in-visual-builder/#post-10104139

    If that’s the case the update would have overwritten any custom edits made to the plugin.

    If you need to roll back to a previous version of the plugin you can download old version at the bottom of this page: https://wordpress.org/plugins/reading-time-wp/advanced/

    Let me know what page builder you’re using. I’m considering adding some kind of functionality for supporting page builders, but with them all behaving differently it’s difficult to identify the best method.

    In particular the issue with leaving in shortcodes is that a shortcode like [shortcode attribute="1" attribute-two="2" attribute-three="3" content="Hi"] makes it very difficult for me to accurately identify what should actually be added to the wordcount.

    Hi Jason I’m using WPBakery Page Builder (formerly Visual Composer).

    With regards to the strip_shortcodes line, I hadn’t done that prior. I’ll add that now as a temporary fix.

    Thanks!

    Plugin Author Jason Yingling

    (@yingling017)

    Unfortunately I don’t have access to that builder to take a look at it’s output. If you’d be willing to send me a sample of how the shortcodes used by the builder are output I can take a look and see if it helps determine a way to allow shortcodes to be counted. You can send it through this form https://jasonyingling.me/contact/.

    kmulhall

    (@kmulhall)

    I’m having this issue as well using the Divi theme.

    Plugin Author Jason Yingling

    (@yingling017)

    Hi @kmulhall,

    Reading Time strips shortcodes as mentioned in this thread. You can alter this as noted in this thread: https://wordpress.org/support/topic/not-counting-posts-made-in-visual-builder/#post-10104139

    However if you make the change you won’t be able to get future updates as they’ll overwrite that setting.

    Plugin Author Jason Yingling

    (@yingling017)

    Hi @leightonrodney,

    I just realized you mentioned you were using a custom post type. The latest version of Reading Time WP added a setting to control reading time being shown across various post types. If you’re using a custom post type you may want to make sure it’s set.

    You can find the setting under Settings > Reading Time WP

    Plugin Author Jason Yingling

    (@yingling017)

    @leightonrodney I just pushed a new update that should default to show the reading time on all posts until the new option has been set. Hopefully that helps your case.

    Plugin Author Jason Yingling

    (@yingling017)

    @kmulhall I also added a new setting to include shortcodes in 1.2.2 that should work better with page builders like Divi.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Reading Time displays < 1’ is closed to new replies.