Support » Fixing WordPress » Reading Options — Posts Per Page

  • It seems that the number you set under the Reading Options for the maximum number of posts to show per page causes a bug. Try viewing all of the entries you made in 2004 in one single page. Are you able to view all of them? Not me. I’m shown the last 35 entries made in 2004; 35 is the number I set under the Reading Options.

    I already tried switching to one of the themes that come with WordPress 1.5, to make sure my customized index file wasn’t the culprit. The problem was still there.

Viewing 15 replies - 1 through 15 (of 33 total)
  • I’m not understanding something here. If you set the option value to 35 and then 35 posts actually show up, then what is wrong?

    Glad I’m not the only one who didn’t understand. I almost posted the same thing earlier but thought maybe I was missing something.

    Well, if someone goes to the folowing URI:

    They should be shown ALL the entries made in 2004. Instead, the number of entries shown is limited to the number set in Reading Options. It worked fine in my installation of WordPress 1.2: visitors were shown all of the month’s entries if they visited archives/year/month and all of the year’s entries if they visited archives/year.

    I hope that helps.

    If you want them to be able to see more than 35 posts, why don’t you set the reading option higher?

    *scratches head* I think I’m confused….

    But I think there’s a misunderstanding on both parts. When you view the archives you do see the posts from that corresponding month, year, or category – but since you set your reading options to show 35 posts, that’s what the page will load with. If you want to view older posts beyond the first 35, you’ll have to use the nav links to go between pages. If you want more posts on the page, just set the number higher. (Though 35 is kind of a lot, imho.)

    Are you saying you want ALL of those posts from 2004 to show up on one continuous (very long!) page? Because I don’t know how to do that…! Or if it’s even possible.

    If you go to you’re shown the most recent 20 (or so) entries. But, if you visit you’re shown ALL entries made in 2004. That’s the way my blog used to work. A predetermined number of entries/days are shown when displaying the main page (the number is set at admin settings), but the setting has NO bearing on how many entries are shown when one is viewing an archived month or year worth of entries. Think about it… when a visitor clicks on “December 2004″… do they expect to see the last x-entries (or x-days) for that month, or ALL entries made that month?

    The way it’s working for my blog now, I can’t set the posts-per-page to be too low because then when people click on “October 2004” (for example) they are shown only the last x-number of entries that month and have no access to the first entries made that month. I don’t wanna set it too high because then the main page takes longer-than-I-desire to load. But how about setting it low for the main page and a flexible, unspecified amount when viewing an archived month or year? That’s how it used to work for me in Mingus.

    Alrighty then…

    I’ve set the max number of posts to display to… 8. I’ve re-enabled the nav buttons (previous and next). Guess I must get used to this.

    I’m confused, too. In 1.2.2, I had my main page set to display the last 7 entries, but my “Categories” and “Archives” would should all posts in that category or month (they weren’t controlled by the limit). As it is now with 1.5, no one can look at posts made the first 3 weeks of each month, for instance. I’ll use prev and next if this can’t be fixed, but I don’t know how to do so. Is it a plugin?

    This plugin will allow you to set a different number of posts per page for the main page, category pages, date pages, etc. I’m pretty sure it’s exactly what you’re looking for.

    I’ve tested it with 1.5 and it works perfectly. I’m going to use it myself just as soon as I find a way to keep it from messing up the hacks I’ve made to Nicer Archives.

    I installed the plug-in and it works. As an added bonus, when you’re shown an archived day, month, or year the entries are shown in ascending order (i.e. if showing a year, january entries are at the top and december entries at the bottom). I’m not used to it being that way, but blogs make more sense that way.

    Good find, Hanover.

    This is just what I need for my site, but I am totally new to WordPress and CSS and PHP as of yesterday, and facing a steep learning curve as I customize my site (, though I am liking WP as I become a little less scared of it. Which file do I insert this code into, and where in the file should it go? I have WordPress 1.5. Thank you so much if you can help me!

    elizdelphi: I think you just have to save the file, change the file extension to .php instead of .phps, and upload it to yous plugins directory on your server.

    From there you can activate it and set different posts per page…

    Thanks for the link to the plugin — I was having the same post-number problem , and it works great!

    Just a side note for srdusky:
    In your post above you are totally wrong about the number of all posts an webtoolscollection site.
    Take a look at this page: to have an idea that even just the list of the titles is much, mucj longer than what you showed as “all” 2004 posts 🙂

    I have been having the exact same problem!!!

    I want 10 posts on my main page and all posts for a month on the archives page. I am using wordpress through though… Im not sure how to use the plugin. Is there a special way to upload it to the plugins. Please help.

Viewing 15 replies - 1 through 15 (of 33 total)
  • The topic ‘Reading Options — Posts Per Page’ is closed to new replies.