Support » Theme: Twenty Nineteen » Settings Reading is missing “Your Homepage displays”

  • Resolved patbell101

    (@patbell101)


    Just a test site – installed twentynineteen and trying to set a homepage… But no “Your Homepage displays” in settings-reading. Has it moved somewhere else (cos it ain’t in customiser either). It looks like it the post page or nothing. All plugins disabled too.

    Whoops?

    The page I need help with: [log in to see the link]

Viewing 14 replies - 1 through 14 (of 14 total)
  • Moderator Andrew Nevins

    (@anevins)

    WCLDN 2018 Contributor | Volunteer support

    If I understand your query correctly, that section doesn’t exist any more with the aim of utilising the Gutenberg editor for setting up the Homepage.

    OK yes, I just changed themes and its the same there. I really want to like Gutenberg but if I understand you correctly the home page defaults to the blog and there is no way obvious way to change this. I have implemented WP over dozens of sites for 5 years and if it puzzles me, what’s a new user going to think? It will seem as if WordPress has just made a giant leap back in time and is now just a blogging platform again.

    I have many sites where the blog is not the home page so I presume it must be possible to set the home page to not be a post somewhere. Try as I might I can’t see it on the Gutenberg editor.

    I will go looking and come back here if I find the solution, but if anyone is listening this might need to be more obvious.

    Moderator Andrew Nevins

    (@anevins)

    WCLDN 2018 Contributor | Volunteer support

    Looking at the theme’s demo it does sound possible: https://2019.wordpress.net/

    I understand your frustrations. Would you be in a position to help make the experience for a new user easier from the problems you have faced so far/ will face in the future with 2019?

    Well, I don’t think this is what you had in mind but there is a workaround.

    If you activate the classic editor plugin, set the static home page and then deactivate the classic editor… settings-reading keeps the ability to set the static front page (absent in default Gutenberg update).

    So far it has been hard to know what is just the learning curve and what is a flaw. I would guess this to be a flaw. I haven’t gone far into the new update yet – but my workaround suggests that my existing static home page sites will retain the ability to set the static front page. Not sure if I feel qualified to complain – its not as if I can fix the issue, just to point it out. There are a lot of naysayers out there and I’d hate to be just another one of them.

    I have WP 5.0 running on my site and I use the Twenty Nineteen theme. I have a static front page and a different page for the blog posts.

    I am pretty sure that the setting is not removed from the admin or from the Customizer, so I am not sure what the problem is on your site/with your setup.

    Do you have other plugins running? Make also sure that you first select the option to set a static page as a front page (it should be there) to be able to select the page.

    Its only on new sites. Try a totally new (from scratch) install. I have done this several times on different installations. Plugins ALL disabled.

    It works fine once the front page has been defined eg existing sites or if I enable the classic editor set the front page and then deactivate the classic editor. Otherwise there is just no entries for choosing whether to have posts as home or to specify which static page.

    On a new local install with WP 5.0, Twenty Nineteen theme and no plugins, I have the option to choose a static homepage.

    I have seen in the past a missing static homepage option when pages are all either drafts or private pages. Do you have at least one published page that is set to public or password protected?

    Do you have any non-default options set in the wp-config.php file? Is there something custom in the way you install a new site? Are you using an auto-installer or following the 5 minute install?

    You know I can’t repeat the problem now. But anyway it might be good to have the workaround just in case. I did have a sample published page and plugins disabled but when I try again on a brand new install, and its fine. Perhaps its that I had a brand new non WP5 install and updated it?

    Whatever, there’s a workaround just in case

    I just installed a fresh WP5.0 site and I too cannot figure out how to set the default homepage. Where/how??

    as I said above
    ” activate the classic editor plugin, set the static home page and then deactivate the classic editor”

    I did that but discovered I had to first create a page with the slug “home” for it to show up in the Reading Settings area. All is good now.

    @patbell101 I also had the same problem – missing “Your homepage displays’ option in Reading Settings.

    Fortunately your workaround worked for me and I can see the homepage setting option now.

    BUT… this is definitely a bug as far as fresh WP installs go. Hope the mothership addresses this issue.

    I experienced the same issue. Reading the answers above, I tried to publish a home page that was NOT on private, and voilà: problem solved, the option to set a static home page appeared out of nowhere.

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator 🚀

    The “Your homepage displays” setting will appear at Settings > Reading in your site’s Dashboard if (and only if) you have at least one publicly published page. This is because, logically, you can’t set a Private or Draft page as the front page of your site.

    For more details, see https://wordpress.org/support/article/creating-a-static-front-page/

    This doesn’t have anything to do with using Twenty Nineteen, Gutenberg, or the Classic Editor.

Viewing 14 replies - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.