WordPress.org

Forums

[resolved] Readers cannot post comments (19 posts)

  1. jbiederbeck
    Member
    Posted 11 months ago #

    Hi there!

    I'm running the CASSIA THEME on wordpress.org. People are not able to comment on my posts, and I would like them to be able to. I have the Jetpack Plugin installed and activated and have activated the "Comments" portion of the Jetpack but comments still cannot be made.

    I've tried deactivating my spam plugins I had installed, but this did not solve the problem.

    My website is: http://applestoziti.com/

    Help please?!

  2. Are they seeing any sort of error when submitting the comment?

  3. jbiederbeck
    Member
    Posted 11 months ago #

    No, when you click the little button that is supposed to allow you to comment it just loads the page again and does nothing. :(

  4. jbiederbeck
    Member
    Posted 11 months ago #

    I am still able to receive "feedback" by inserting a contact form in each individual post. No one else can see these comments though.... they just get sent to me.

  5. Try deactivating all of your plugins, not just the spam ones. If that resolves the issue, reactivate each one individually until you find the cause.

    If that does not resolve the issue, switch to the Twenty Fourteen theme to hopefully rule-out a theme-specific issue (theme functions can interfere like plugins).

  6. jbiederbeck
    Member
    Posted 11 months ago #

    Tried deactivating all plugins and commenting still did not work. Nothing happened when I clicked the comment box.

    Tried to switch theme to Twenty Fourteen and immediately the site only registered as: "Website Under Maintenance. This website is currently under going maintenance. We will be back online shortly. Please check back later!"

    Switched back to my previous theme and now it won't even register that and I have a giveaway going on. Need it fixed ASAP! Help?!

  7. jbiederbeck
    Member
    Posted 11 months ago #

    My site is still showing only this when you try to visit any of its pages:

    "Website Under Maintenance. This website is currently under going maintenance. We will be back online shortly. Please check back later!"

    This happened after switching to the Twenty Fourteen theme to rule out a theme-specific issue for why comments were not functioning correctly on the blog. I switched back to my theme: Cassia.... and it's showing the same message now :(

    Help!?

  8. jbiederbeck
    Member
    Posted 11 months ago #

    FYI....

    I did try going to my site through several browsers to be sure it wasn't a browser-related issue. The same thing is happening on Firefox, Google Chrome, and Safari: "Website Under Maintenance."

  9. jbiederbeck
    Member
    Posted 11 months ago #

    Thanks for helping me out with this by the way!! :)

  10. Use your FTP client, make sure it's set to show invisible files (like .htaccess) and look for a file named .maintenance in your root or WordPress directory. If you find it, delete it.

    If you don't see it, the notice is likely being added by a plugin.

  11. jbiederbeck
    Member
    Posted 11 months ago #

    lol .... yes, the answer was simple! When I deactivated all the plugins I then re-activated ALL of them... not just the ones that had previously been active. I forgot about the "Smart Maintenance Mode" plugin :). Oops!

  12. jbiederbeck
    Member
    Posted 11 months ago #

    Okay, so now with the "Maintenance" Plugin deactivated I tried the Twenty Fourteen theme and there is no place for people to leave comments. If I added a "Contact Form" {from the Jetpack} to an individual post they could leave feedback there, but not on the post itself where others could see it, too.

    So, it seems the problem is not theme specific?

    I double checked to be sure my "Comments" were activated in Jetpack but maybe I need to be using something else for comments on my site?

    Thanks! :)

  13. When you switch on 2014, there was no comment form below posts?

    If so, edit a post and make sure that "Comments" is checked in the Discussion module below the post editor. If you can't find a Discussion module below the post editor, click the Screen Options tab near the top-right and check "Discussion."

  14. jbiederbeck
    Member
    Posted 11 months ago #

    Yes! You were right!

    I switched to the 2014 again and there was no comment form below the posts. So I edited a post and saw that the "Comments Allowed" box was check in the Discussion module and then a comment form showed up on the live post!

    Then I switched back to the Cassia theme and found that there is now a Discussion Module on individual posts {not there before... not sure if this was a glitch?... it seems to have corrected itself!!} Now I can "Allow Comments" and "Allow links/ ping backs" on each individual post.

    Do you know if there's a way to set this as the standard or do I need to manually check this box every time I write and publish a post? I welcome any further feedback you might have on this, but I consider this issue closed!!

    Thank you so much for taking time to go through this issue with me. :)

  15. You can set the default for future posts at Settings -> Discussion in your blog's Dashboard, but existing posts will need to be updated individually.

  16. jbiederbeck
    Member
    Posted 11 months ago #

    Thanks James! :)

  17. You're welcome!

  18. renaplays
    Member
    Posted 10 months ago #

    I have one reader who just started having problems posting her comments, which she has always made from her iPad. Now she can post from her Mac, but not from her iPad. It says "sending comment" then gets stuck. I'm guessing this is a problem on her end, in some way. I appreciate if anyone has advice to give her. Thank you.

  19. renaplays, please open your own thread about that: https://wordpress.org/support/forum/how-to-and-troubleshooting#postform

Reply

You must log in to post.

About this Topic