Support » Theme: Responsive » Read This before updating Responsive

  • Theme Author CyberChimps

    (@cyberchimps)


    Hey,

    We are continually working on improving the Responsive theme. To make it simpler for you, every week, we will be updating you about the changes. This week we have added one enhancement, three features, and fixed one issue in the v3.17

    Changes to the blog template:
    In the previous version, the blog template displayed the entire content of each post. This affected the performance of the page as well caused duplicate content issues. This also caused a severe load on the server. Particularly for blogs having a large number of articles.

    With this update, you can choose to show the entire content or post excerpt. This option is available in the customizer.

    Changes to the blog template pagination:
    Before this version, the blog page was showing all posts with default previous and next links.

    With this update, the blog and archive pages will come with numeric pagination.

    If you have a child theme:
    If you have overridden the home.php template you may not see the default previous and next links. To get numeric pagination you will have to update your child theme with updated function

    Added Schema markup support:

    The new update adds schema markup. It provides information about the structure of your website to search engines.

    Changes to footer design:
    Previously, the site footer only came with a white background and black text color

    In this update, we have added customizer options to change the site footer design.

    Removed jQuery dependency:
    We have worked on improving the page speed. This version removes jquery dependency from the responsive theme. This has reduced the page size by 33KB.

    If you have a child theme:
    Please check if have used any jQuery functions in your code. You will have to include jQuery with wp_enqueue_script(“jquery”);

Viewing 8 replies - 1 through 8 (of 8 total)
  • Theme Author CyberChimps

    (@cyberchimps)

    This week we have added two enhancements in the v3.18.

    Changes in the blog entries design:
    To improve blog design, we have added four customization settings for controlling the layout of the blog.
    -Pagination: Now you can enable numeric pagination or infinite scroll for blog page.
    -Length of the excerpt shown on the blog page.
    -Setting to change read more text
    -Show read more as link or button

    Changes in the footer:
    Before this version, the footer scroll-to-top did not have any customization options.
    With this update, you will be able to customize the following:
    -Scroll-to-top button position
    -It’s Icon size, color & border-radius
    -You can also choose devices to show/hide icon.

    Now you can also add spacing to your footer.

    If you have a child theme:

    Please update your footer.php with the latest code from the parent theme.

    Replace,
    <div id=”scroll” onclick=”topFunction()” title=”Scroll to Top” style=”display: block;”>Top<span></span></div>
    With
    <div id=”scroll” onclick=”topFunction()” title=”Scroll to Top” style=”display: block;”>Top<span></span></div>

    Question – before this update my page titles were not links. Now half of them show up as links and half do not. How do I make it so the page titles are not links? It doesn’t make sense for the page title to link to the page you are already on.

    Theme Author CyberChimps

    (@cyberchimps)

    Thank you for reporting @melissaschmitt. Our developers will update you shortly on this.

    Thank you! Here is a page that shows an example: https://www.prairieviewpto.org/picnic/

    Since at least 3.17 but maybe earlier, inclusive of this mornings 3.18, we’ve had an issue where we get the following error on our website:

    Notice: Undefined variable: responsive_options in /home/verduins/public_html/wp-content/themes/responsive/header.php on line 130

    Depending on the version the error might appear on 129, 130 or 131
    The fix for the error is to find the line directly before the error in header.php and change it:
    From:
    <?php
    to:
    <?php global $responsive_options;

    and then the error goes away. I have to manually make this change every time the theme gets updated.

    I’ve tried commenting on the thread at https://cyberchimps.com/help/forum/topic/undefined-variable-responsive_options-in-header-php-on-line-153/

    But I don’t have a log in. I’ve asked for one, but it says “ERROR: Your account is still pending approval.”

    If you search google for “Notice: Undefined variable: responsive_options in public_html/wp-content/themes/responsive/header.php on line” you can pull up lots of websites affected by this.

    Theme Author CyberChimps

    (@cyberchimps)

    Thanks, @mikeverduin for reporting the issue. Our developers will be launching the fix in the next update.

    @melissaschmitt This issue has been fixed by our developers and will be available in the next update. We will notify you once it is fixed.

    Thank you!

    Thanks!

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.