WordPress.org

Support

Support » Themes and Templates » 'Read More' not working on modified Kubrick (read the codex)

'Read More' not working on modified Kubrick (read the codex)

  • I did not create this site, just being asked to maintain it. The client emailed to say “Hey, the “read more” text isn’t showing up anymore and all it has is [...] “. http://www.outreachnc.com/

    I’m not at all familiar with Kubrick (or this site), and I’m assuming that is what this theme is built from as I noticed reference to it in the code.

    Ok – the posts are showing on the ‘front’ page, as set in “Settings –> Reading Settings”.

    I went in and looked and they were (are?) using a plugin called “Content and Excerpt Word Limit”. I looked at its settings which say:

    Instead of the_excerpt() or the_content(), use <? php excerpt('word-limit'); ?> or <? php content('word-limit'); ?> within your loop to limit the words for each.

    Example: <? php excerpt('25'); ?>.

    I then went and looked at the index.php and home.php and couldn’t find reference to this. Tried to make the substitution, still nothing.

    Next, I deactivated the plugin, and a few others, tried to reactive them one by one. Nothing.

    I then opened the posts to see if they were actually using any kind of short code [...] , or the <!--more--> and there were no references to anything to truncate the post within the post itself.

    Then I even switched to the ‘default’ (blue header) theme and the 2010 theme and still no ‘read more’ text (in both those themes I get ‘ … ‘ at the end of the cut off post). Still nothing.

    In all this I noticed that the ‘functions.php’ file was named ‘functionsX.php’. Hmmm, might not be related but thought it was odd.

    Next, I started looking at the home.php and index.php – and digging in the codex and the forum, and tried a few tips I found on forum posts that didn’t work.

    Anyone have any clues?

Viewing 3 replies - 1 through 3 (of 3 total)
  • esmi

    @esmi

    Forum Moderator

    That’s not the original Kubrick theme. It’s a custom theme.

    I realized it has been modified from the original… but… my problem still exists.

    Anyone?

    @aardvarkgirl If you look in the loop in index.php, how is the content built?

    Does it use the_content() or the_excerpt()?

    • If it uses the_excerpt(), the […] is added automatically at the end of it.
    • If it uses the_content, I would go ahead and deativate that Content and Excerpt Word Limit plugin, to see if that is what causing the issue. if they are using the <!–more–> tag correctly in their posts, they wouldn’t need that plugin.
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘'Read More' not working on modified Kubrick (read the codex)’ is closed to new replies.
Skip to toolbar