Support » Fixing WordPress » Read more not working

  • Resolved lukeprog


    I switched to show summaries in Options->Reading, then edited one of my posts to include a <!--more--> tag. Now, in my archive/search/front pages, posts show up with no images at top and only 55 words showing, instead of displaying everything (including images) up to the <!--more--> tag!

    How do I get this to work properly?


Viewing 8 replies - 1 through 8 (of 8 total)
  • Unfortunately that doesn’t work, the code that displays the post up to the “more” tag stips all html from the post, so all images will disappear.
    I had this problem on my site too…

    So, how can I achieve partial posts or summaries?

    I think I answered this in another thread, but <!--more--> certainly does work. Look at it in action here:

    All I did was add the <!--more--> tag in the spots where I wanted it to appear — and you can see that the images (which are above the more tag) still appear.

    If you want to only show excerpts in posts (on the blog home page), then edit index.php in your theme, and replace the_content with the_excerpt. However, this can have its own problems.

    By the way, Options > Reading > Summaries has to do with RSS feeds, not what appears on the blog’s home page.

    DianeV, why do you think the more Quicktag isn’t working for me, then?

    Well, by coincidence, there’s a similar current thread in which it was discovered that the blogger was using the WYSIWYG editor for posting, and the more tag wasn’t working … but there’s a built-in solution for the WYSIWYG editor:

    Hopefully, that’s it.

    I switched themes and now it’s working. Apparently my theme was breaking the Read More functionality.

    Glad it’s sorted out. Perhaps you can mark this thread [Resolved].

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Read more not working’ is closed to new replies.