Support » Plugin: Category Posts Widget » Read More link of 1st Post Becomes the Title of 2nd Post

  • Resolved dlcmarlin

    (@dlcmarlin)


    Title says it-

    When the excerpt of the first post hits the word limit and triggers the “Read More…” button to appear, instead of this, it uses the title of the second post and mashes the posts together.

    The page I need help with: [log in to see the link]

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Daniel Floeter

    (@kometschuh)

    Sorry, I can’t get your issue?
    I see the “excerpt more” and if I click on that link the post is shown.
    Please describe it in more details what the wrong behavior is

    Sorry about that- I had disabled the post before I went home. It is live again.

    The Read more link for the first post appears to be using the title link of the second post- as in the title of the second post appears where the read more of the first should be. This messes up the alignment of the second post.

    Plugin Author Daniel Floeter

    (@kometschuh)

    There are HTML elements in the headline which cause the issue.

    Can you try the new version 4.9 which is not yet released on wordpress_org but that version is very stable and tested https://github.com/tiptoppress/category-posts-widget/tree/4.9

    Another tipp can be to try our excerpt extension with our pro widget. The pro version can be tested for free on a localhost WordPress installation http://tiptoppress.com/extensions/excerpt-extension/

    Thank you for helping!

    Will this version allow me to use HTML text flags in both the title and the excerpt?

    Plugin Author Daniel Floeter

    (@kometschuh)

    It is possible to use HTML in the excerpt text.
    I do not really know if it works for the title.
    How do you set the HTML to your post title?

    I have just been using the b and i tags in the post title itself. I’m open to any better options- but I do need to be able to bold and italicize certain words.

    Plugin Author Daniel Floeter

    (@kometschuh)

    to use HTML elements in the title is not the problem. The widget will show rendered HTML.

    The issue will be there are not valide characters used which cause not closing tags.

    P.S.: At the moment I can’t reach the url you have written above. Can you set the site online again or send us a new link

    The site is up again.

    Which characters can I use that will allow “Dynalantic Corp.” to appear bold and italicized in the title and excerpts? Strong and em both cause the weird issue I first noted here.

    I’m still baffled as to why in the second post- the bold and italics work on the first instance of “Dynalantic” but not in any of the others.

    • This reply was modified 8 months, 3 weeks ago by  dlcmarlin.
    Plugin Author Daniel Floeter

    (@kometschuh)

    You can try: <i><b>Dynalantic Corp.</b></i>

    What is not allowed are nested errors like <b><i>text</b><i> and it can get problems with quotation marks "text". Do you want to use inline styles for the HTML elements? Thats what I don’t try. Better is to use separate CSS rules may added with the customizer.

    And I see the page is well now?

    Removing the <i> and <b> tags from the title fixed the layout- but still leaves me with the problem of not having the bold and italics.

    Plugin Author Daniel Floeter

    (@kometschuh)

    You you send us a support message to our tiptoppress_com website?

    I can do that.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Read More link of 1st Post Becomes the Title of 2nd Post’ is closed to new replies.