• OscarGuy

    (@oscarguy)


    I have been working on a block build for my site and I wanted to try a diff length for the excerpts and found an addon. It didn’t do what I wanted it to do, so I deleted it, but ever since I installed it, the Read More link that’s showing up in the editor isn’t showing up on the site itself. I have no idea where to even look for code that might have been inserted, but not removed when I deactivated the plugin.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Hi @oscarguy,

    I checked your website and saw that you are using the TwentyTwentyThree which you have nicely customized using the site editor.

    In that theme, by default, there is no Read More link for the post excerpt but you can add one:

    On your homepage, click “Edit Site” in the toolbar and then you should see your site with one post that has the excerpt. If you click that excerpt, you can customize that.

    Note that at the bottom of that block it says: Add “read more” link text with a dotted underline and in grey. If you click that, you can type your own text, for example “Read More”.

    Hit “Save” and your site show now have Read More links.

    Thread Starter OscarGuy

    (@oscarguy)

    Thanks, but therein lies the problem. In the editor, it shows a read more link and it’s customized, but when I view the page, it’s not there. It was there before I added the plugin, but after removing the plugin, it didn’t come back.

    Did you try to run your site in troubleshooting mode (Tools > Site Health > Troubleshooting)? In that mode all plugins are deactivated and thus you should be able to see if it is a plugin causing this or if the problem is in the templates.

    Thread Starter OscarGuy

    (@oscarguy)

    I don’t have that available. It just tells me what I need to do to update my site health.

    Thread Starter OscarGuy

    (@oscarguy)

    I fixed it. I didn’t realize it had removed what I’d already customized, but it reset them all, so now I’ve got what I wanted.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Read More Link Has Disappeared’ is closed to new replies.