WordPress.org

Support

Support » How-To and Troubleshooting » “read more” link doesn’t work in konqueror

“read more” link doesn’t work in konqueror

  • I have the following problem, if I insert the “read more” tag into a post (<!–more–>), then the following code will be generated (example)


    <p> <a href="http://www.daemon.de/blog/2005/05/22/ads-quake/#more-36"><br />
    <p class="serif"><strong>Weiterlesen &raquo;</strong>
    </a>
    </p>

    In the konqueror browser this doesn’t render to a working link.

    If I edit the templates and remove the <p class="serif"> part, then it works as expected.

    My blog is here: http://www.daemon.de/blog/

    The template I am using is based on the default template.

    Beside I think this is invalid HTML, it should better look like this:


    <p class="serif"><a href="http://www.daemon.de/blog/2005/05/22/ads-quake/#more-36"><br />
    <strong>Weiterlesen &raquo;</strong>
    </a>
    </p>

    regads, scip

Viewing 4 replies - 1 through 4 (of 4 total)
  • It’s going to be difficult to get an answer to this because I don’t think that many people are using that browser. If the site validates (did you test it?) then it should work fine across most browsers.

    I checked your validation and you have some fixing to do. That may or may not be your problem.

    Your site is also set up in tables which is BAD form. Tables are for data not for design. I hope that isn’t a WordPress Theme as those are not encouraged at all. Tables cause all kinds of head aches if you miss a slip of code.

    The second one you listed is valid HTML, but fix the rest of the invalid HTML and maybe your problem will be solved.

    Finally I changed the dtd (xhtml 1.0 now) and fixed all errors, now the page validates to be correct, and – guess – the more link (with the tags) works now as expected in konqueror too.

    Thanks for the hint,

    scip

    Ahem – after fixing all errors I re-added the tags to the read-more links, now it looks again like in the default template:

    <?php the_content('<strong>Weiterlesen &raquo;</strong>
    '); ?>

    While the link works, it is invalid xhtml now (as I already mentioned in my first post), the w3c validator doesn’t like it ( inside ).

    I used the default-deutsch theme as base, which is a translation of kubric: http://www.journal.kylaloo.net/2005-02/wp-kubrick-template-in-deutsch

    , it contains the error too.

    The usage looks right, and you must have fixed it because the validation shows no errors.

    Correction – sort of – the page validates but you still have some CSS errors to fix. It just never ends. 😉

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘“read more” link doesn’t work in konqueror’ is closed to new replies.
Skip to toolbar