WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Read More button

[Resolved] Read More button

Viewing 14 replies - 1 through 14 (of 14 total)
  • SiteSubscribe
    Member

    @sitesubscribe

    I was also hoping for an editable read more link when using excerpts.

    Plugin Author 2046
    Participant

    @o-o

    Download Version 0.9.4.5 you’ll find what you are looking for.

    SiteSubscribe
    Member

    @sitesubscribe

    Thank you for the quick update!

    The read more link works great if I set content to show.

    If I want to display just the excerpt and the more tag (how I usually use post list widgets), how do I get the read more link to display? I’ve added some read more text into a content view element and assigned it as excerpt.

    Is there a way to make the read more link show up at the defined excerpt limit automatically without having to manually put a a < !–more – – > break into each post? I’ve seen some post list widgets do that, and it would be great to have that functionality in your awesome plugin.

    Thanks!

    SiteSubscribe
    Member

    @sitesubscribe

    Ok, I notice that if I DON’T manually enter an excerpt into WP excerpt field than the ‘more >>’ link shows up.

    This is very similar to how I would want it to work, except that:
    1) the more link isn’t using the widget configured more text (in this case), and
    2) if I DO manually enter WP excerpt then there is no more link at all (I would like it to show in this case too)

    SiteSubscribe
    Member

    @sitesubscribe

    Sorry, to bug you, but the pagenavi doesn’t seem to work.

    I have pagenavi plugin installed & activated, and the pagenavi links show at the bottom of the Easy post list, but after clicking on any page, like page 4, it always returns to page 1 of the post list.

    SiteSubscribe
    Member

    @sitesubscribe

    Fixed this one: had to use product_cat not category.

    All WooCommerce products show when using post type product, but when I add a taxonomy filter set to category using a product category ID (434) there are no results.

    Fixed this one: had to use product_cat not category.

    SiteSubscribe
    Member

    @sitesubscribe

    I have scafold set to ‘one per row’, and class set to ‘each’.

    Widget column div class is being set to ‘eacheacheacheach’ (on the 4th post) by the plugin.

    I don’t think that is the intended result.

    SiteSubscribe
    Member

    @sitesubscribe

    pagenavi works on this page of posts by News category:
    http://irfnews.wordpressmash.com/news

    but not on this page of posts by News –> Press Releases sub-category:
    http://irfnews.wordpressmash.com/press-releases

    I believe the widget settings are nearly identical (with exception of no image in content of the latter)

    Plugin Author 2046
    Participant

    @o-o

    hello

    re: wp-pagenavi.. both links has navigation so I guess the problem is solved

    re: class .. you are right.. FIXED in new release

    re: excerpt.. your explanation is bit confusing to me, wwhat is “WP excerpt”?

    Thanks to your link I have figured out another bug with edit link.. FIXED

    thanks

    SiteSubscribe
    Member

    @sitesubscribe

    Again, thanks for reply.

    “WP excerpt” would mean the optional excerpt field within the post editor where you can place summary text.

    Ideally I’d want to be able to list something kind of like this:
    http://sitesubscribe.com/blog

    (featured image, title, excerpt, more link)

    The pagenavi links are there, but on a sub-category listing when clicking on them they don’t produce correct result (always shows 1st page result only, no matter what page of listing you try to navigate to). This seems to only be the case for a sub-category listing.

    Here is an example of pagenavi not working on the Easy list of sub-category blog posts:
    http://50.87.144.128/~irfnews/press-releases/

    Plugin Author 2046
    Participant

    @o-o

    WP excerpt:
    I have checked that code and for some reason the WP function get_the_exerpt or even get_excerpt doesn’t echo the more link. Seams it becomes a default WP behavior in this case.

    The excerpt can be done this way too:
    http://codex.wordpress.org/Function_Reference/the_excerpt
    “..it will display an automatic excerpt which refers to the first 55 words of the post’s content. “..if the excerpt field is not actually used, if it is used then it will use this text.

    …anyway I have mimicked the expected behavior in next release (0.9.4.7).

    pagenavi
    seams like you hit this problem
    http://scribu.net/wordpress/wp-pagenavi/right-way-to-use-query_posts.html

    the case is that the way how it should be done is this
    http://scribu.net/wordpress/wp-pagenavi/
    code: wp_pagenavi( array( ‘query’ => $my_query ) );

    Easy does this:
    wp_pagenavi( array( ‘query’ => $easy_query ) );

    Which is exactly how it should be, so if it produces any unexpected result, well I think there is a problem on the side of WP-pagenavi.

    note: the wp-pagenavi will work with easy if you use the wp_pagenavi brick in the Easy widget.. which actually gives the wp-pagenavi right query object as mentioned above. In other words, do not use the code in the template, it will not work as expected.

    SiteSubscribe
    Member

    @sitesubscribe

    Thanks for all the help and quick replies.

    I just left a 5 star review, you deserve it.

    I’m looking forward to trying out the latest version.

    Plugin Author 2046
    Participant

    @o-o

    thanks,
    let me know if it works for you.

    Plugin Author 2046
    Participant

    @o-o

    Believe it’s okej now.. marking as resolved. if not reopen it if you like.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘[Resolved] Read More button’ is closed to new replies.