WordPress.org

Support

Support » Plugins and Hacks » Cnhk Slideshow [ENDED] » [Resolved] read all support message, but still not working

[Resolved] read all support message, but still not working

  • Hi, Rija…
    i used and installed the plugins inside my wp site, but

    it seem that the slideshow is not shown at my wp site…
    i did read all of the support messages here, but i still cannot make the slideshow works…

    what i do :
    add/upload 2 slides images….

    i did create “tryout” slideshow name….

    drag the slide images from left side to the right side (slide order from top to bottom)…

    apply the cnhk_slideshow to sidebar widget… and choose the existing slideshow “tryout”..

    but still, i cannot see the slideshow… :<

    not only at the widget, i did try to implement it in my first post, but, still nothing…

    this will be my site where i try to implement the code :
    http://crystalprocovers.com/wp-portfolios/1/

    did i missed something here?

    http://wordpress.org/plugins/cnhk-slideshow/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Rija Rajaonah

    @cnhk_systems

    Hello,

    it seems that you’ve done everything right but I can’t see anything at the link you mentioned. To be sure, it’s better if I could see a page where you tried to run the slideshow.

    But following the problem that you encountered, I looked on my plugin’s code and noticed something. If you use a security plugin that modifies the WordPress’s constant WP_CONTENT_DIR/WP_CONTENT_URL, or edit the wp-config.php file manually, the problem you described might happen (everything is OK on the backend and nothing on the site). I’m a bit busy now but I’ll fix this issue as soon as I can (tomorrow at the latest).

    Hi, Rija…
    thank you for your reply message…
    sorry…, i just upload the wp site again with the plugin implemented at the sidebar so that you can check the site…

    just for info, i didn’t touch any wp-admin php file…
    all i did was install the wordpress to my url,
    install the theme, install your plugin, and setting it…

    beside the slideshow at the sidebar part, i also try to implement the php code into the index file right below the header part…
    i put the code like this one (3rd line is the code):

    ========
    <?php get_header(); ?>

    <div id=”content”>

    <?php if ( function_exists( ‘cnhk_slideshow’ ) ) cnhk_slideshow( ‘gallery1’ ); ?>

    =========

    but, no slideshow image is emerge with this code also..

    i appreciate your time to look at this :>

    THank you so much, and

    waiting for your reply…

    Warm regards,
    Hendy AUgust

    Plugin Author Rija Rajaonah

    @cnhk_systems

    Ok. It might be a problem with PHP.

    Try to edit the file: “cnhk-slideshow/classes/cnhkss.class.php”. It’s at the top part of the plugin’s files list when I used the editor on my dashboard (wp 3.6.1).

    Look for a function called “wp_head()” within this file. At the end of this function there is something like this:

    <script type="text/javascript">
        var cnhkOptions = <?php echo json_encode($options, JSON_FORCE_OBJECT); ?>
    </script>

    Remove the parameter JSON_FORCE_OBJECT. So it should look like :

    <script type="text/javascript">
        var cnhkOptions = <?php echo json_encode($options); ?>
    </script>

    This parameter is unavailable before PHP 5.3.0 while WP 3.6.1 requires only 5.2.4.

    That is abosolutely FANTASTIC Rija :>
    thank you so much for correcting the mistake…

    THe slideshow works wonderful :>

    Thank you again for your awesome and fast support :>

    Warm regards,
    hendy August

    Hi there, im currently in the same position where the slideshow does not work. I have tried all of the above; but it still does not work. The page is attached below:

    http://techtorium.co.nz/comptia/

    The slideshow ‘Widget’ does work.

    I have created 2x test slides (Test Slideshow & CompTIA) The short-codes I have tested are as follows:

    [cnhk_slideshow name=”Test Slideshow”]

    [cnhk_slideshow name=”CompTIA”]

    [cnhk_slideshow]”CompTIA”[/cnhk_slideshow]

    Neither of these work. Im completely stuck and unsure what to do. Your help is greatly appreciated.

    Regards,
    Sam

    I have try above but it not working http://www.ttmlaundry.com/

    Remove the parameter JSON_FORCE_OBJECT.

    <script type="text/javascript">
        var cnhkOptions = <?php echo json_encode($options); ?>
    </script>

    “cnhk-slideshow/classes/cnhkss.class.php”

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Resolved] read all support message, but still not working’ is closed to new replies.
Skip to toolbar