Support » Fixing WordPress » Re-write not working properly

  • Resolved shieldfire

    (@shieldfire)


    I know it’s a faq most likely. I’ve been over a bunch of docs on-line and got so far as I get the pages to show using “plain” permalinks. Once I change permalinks to any other option, I get a 404. Apache mod-rewrite is installed and enabled.

    • I used Duplicator to move pages from a provider that managed to down my server twice in a week to something hopefully more reliable.
    • Blank admin-page, lots of 404s.
    • Finally after fiddling with .htaccess and whatnot remembered to “Lets encrypt” the new server as well.
    • 404s.
    • Changed to the duplicator backuped .htaccess, and the admin page said a plugin was out of line so disabled it.
    • Now when I go plain permalink I get a sub-page.
    • Now when I go my prior setting (Day/name) I get a 404.
    • Removed .htaccess entirely
    • 404s

    Halp?

    • This topic was modified 4 years ago by shieldfire.
    • This topic was modified 4 years ago by shieldfire.
Viewing 2 replies - 1 through 2 (of 2 total)
  • Thread Starter shieldfire

    (@shieldfire)

    It seems that it is the mod-rewrite module that is misbehaving, I have the same problem on a site that I built from scratch.

    Thread Starter shieldfire

    (@shieldfire)

    Found this:
    /etc/apache2/apache2.conf had an entry for the base web Directory with
    AllowOverwrite None
    changing it to
    AllowOverwrite All

    and restarting Apache
    systemctl restart apache2

    solved the problem.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Re-write not working properly’ is closed to new replies.